8

I have been getting overlays as such on my Nexus 5, Nexus 6 and now my Nexus 6P - haven't noticed exactly when they start to appear and have yet to find a way to disable them - please take a look at the following image:

screenshot
Screenshot (click to enlarge)

If you look at the upper right, you should notice a few buttons on the viewfinder. It used to be just two, now I have three after the camera app updated. They were not there when I initially got any of my Nexus devices but shortly presented themselves afterwards.

I do use my Nexus devices for debugging so I have disabled debug mode to see if there was any connection, but this does not seem to be the case.

Is there sort sort of hidden button I must press (ex; how the developer menu is activated) in order to hide these buttons once again?

  • The buttons in the upper-right corner seem to be the flash indicator, HDR mode, and self-timer. To what buttons are you referring? – RockPaperLizard Jan 27 '16 at 2:30
6

I recently had the same issue with my 6P, running 6.0.1 and the latest Google Camera version 3.1.021. It turned out to be a result of having the Screenwise Trends Panel app installed on all my phones. Enabling it in Accessibility Services causes the buttons to show up. From my searching there is no real solution other than to disable the Accessibility Service toggle for Screenwise. Then the buttons go away.

  • AH! Wow, seriously! Yep, I make use of Screenwise as well for some cheap Google Play funds - guess I can uninstall it on my main device at least. – avluis Jan 26 '16 at 20:07
3

The buttons overlay (i.e. Z-, Z+, and 5 SECOND BURST) are part of Android's accessibility feature, TalkBack. Refer to Google Camera Help - Use TalkBack with Google Camera.

To hide the buttons, you need to turn off TalkBack feature on Android Settings - Accessibility - TalkBack - tap to toggle off.

Note: the buttons are integrated to the TalkBack feature, so there's no way to hide the buttons without turning TalkBack feature.

  • This is neat, but TalkBack is off on my device. Turning it on then back off, does not get rid of the buttons either. – avluis Dec 12 '15 at 22:43
  • @avluis I see... this is the only clue I have tested and proven on my device, but it seems there's something more in your case... I'll try to experiment with it again, but I can't promise the fix... Edit: try to switch off any Accessibility option and see if it helps. Just now when I tested Switch Access accessibility, the buttons also appeared. – Andrew T. Dec 12 '15 at 23:04
3

I too had this menu enabled today. Later I found that, I was playing around with accessibility settings today. I've (accidentally) enabled "Switch access", so I got this menu in camera app.

Now after disabling the Switch access, this menu was gone in camera.

protected by Community May 17 '18 at 8:16

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.