5

I have an Acer Iconia A500 tablet with Android 3.1. I cannot mount any USB flash drives. File Manager HD and other similar apps display "Directory is empty" in /mnt/usb_storage/. I have tried use a flash drive formatted FAT32, and my USB port works (I've checked with a USB mouse). How can I get this to work?

  • What types of drives have you tried? There are some (mostly older) drives that won't work even on a PC without custom drivers. – Matthew Read Sep 4 '11 at 22:40
  • It is just flash memory. USB Flash Silicon-Power 8 Gb. It works on all PC without drivers. – Eugene Gluhotorenko Sep 5 '11 at 7:50
2

You have to use File Manager HD and do the following Steps :

  1. On the panel at the left tap Storage.

  2. On the panel at the top right press the Up arrow until the first directory entry is asec.

  3. Now scroll down through the directory and you should see usb_storage.

    4.Tap usb_storage and you should see your data.

Hope i will help.

From : http://androidforums.com/acer-iconia-tab-a500/358421-iconia-a500-cant-browse-through-usb-flash-drive.html

1

The USB host mount script seems to be on the flaky side. My tab reports the drive is inserted but is not mounted to /mnt/usb_storage. A reboot is the only way I've found to fix this.

-3

Being 8GB I believe it could be a way the flash is using mass storage. Although all drives should be seen, not all are setup by each manufacture the same. Have you tried to format the flash as a 2GB fat32 to determine mass storage feature for the drive or for the tab? I assume that this flash is valid as you have been able to format it. How do any other flash drives work? I also found quite a few HP flash drives have issues as they attempt to install the extra software from the minor partition.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.