3

I can't really reproduce what caused the issue, but all my contacts show up separately, it's like I'm having two contacts with identical name, one in the Google account containing all his phones, emails including his WhatsApp number but not identified as WhatsApp, and another one for each WhatsApp number the contact has.

I thought about deleting all the WhatsApp contacts but I can't seem to find a way to do it.

Here's what it looks like:
enter image description here

I've tried merging accounts on Google and on phone and the system found no duplicates.

It looks like my WhatsApp contacts are stored somewhere on the cloud and needs to be erased then be re-obtained automatically staying as simple contacts, but I haven't found a way to clear all WhatsApp contacts (I have 900 - meaning erasing them manually isn't an option).
I've tried to filter only WhatsApp contacts then choose delete selection but it didn't allow me to do that.

3

I might be a little late, but still, at least for google.

I had the very same problem recently, some whatsapp contacts were separate from original (google / device / doesn't matter). Manual join did not work - phone said contacts joined but they did not.

After some fiddling I found a solution thet worked for me in all cases.

Problem was in phone number format in original contact and in whatsapp. It is possible to store the number either with or without spaces.

Here in Czech Republic these are

  • +420 123 456 789
  • +420123456789

in UK it is

  • +48 1234 567890
  • +481234567890

    etc.

Solution was simple after realizing this, edit all your google contact numbers coresponding to whatsapp and either add the spaces in numbers without them or delete the spaces in numbers which got them.

After that I was able to join manually all contacts with whatsapp contacts.

Hope this helps JirkaBitr

  • 1
    works but would love some automation. – TiloBunt Dec 14 '17 at 4:17
1

If anyone else is coming here and still has the problem. And do not want to manually edit the contacts in different country formats. Here is a simple workaround.

Go-to Contacts app. - settings. - Select contacts to display. - Customize. - Deselect WhatsApp contacts.

You will not see what's app contacts separately when searching for contacts.

1

Editing all the contacts is useless - just try to re-install your whatsapp and you face the issue again (and sooner or later you will re-install when you buy new phone :-) ).

Why it seemed to be helping? Because the contacts were re-sync to your smartphone - you can test it - just add a web page and it will fix the issue as well - the spaces in the number are not important, it just marks the contact for a re-sync.

What helps and much faster is a full re-sync of google contacts to your phone. You can achieve that by simply adding all of them into a new group, which you can revert in next step - 30seconds and everything re-synchronized and working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.