3

I purchased a second hand nexus 5 to find out that the battery indicator is always showing 42% and never updates, regardless of the actual battery charge level.

I tried replacing the battery with the one from my brother`s nexus 5, then replaced the usb port board. Also tried:

  • rooting
  • installing twrp 2.8.7.1
  • elemenalX 6.0 kernel
  • Android 6.0.1
  • Cache and dalvik wipe
  • Use the battery until phone shuts down

Nothing helps, although the indicator jumped to 83% and to 54% after some actions which I dont remember. Maybe after cache wipe, not sure.

Anyone know how to fix this?

  • It might be an issue with the battery controller chip on the device mainboard. I recommend that you get the device checked out by LG. However, if the device is usable, you could not worry about this. Also, if a battery stats app shows OK data, it might be an issue with something else, I'm not sure – Tamoghna Chowdhury Dec 8 '15 at 5:52
  • @TamoghnaChowdhury Thanks. Other than this the device is usable, w hat do you mean by "not worry about this"? (battery stats apps didnt help). – ramiwi Dec 8 '15 at 13:40
  • Suggest add "Charging tag" also – beeshyams Dec 8 '15 at 15:10
4

Battery contains the chip which provides information to fuel gauge hardware and drivers. Since you have already done that, next is to determine if the problem is with fuel gauge drivers/ software or hardware.

Wipe clean your phone (cache, dalvik and system) and flash stock ROM for your phone. Don't install apps. Switch to safe mode, charge for about three hours (will certainly top the battery) and if the behaviour is same, then it is NOT OS related (yes, try all this with external SD and SIM removed...doesn't sound logical to do this and I agree but for some unexplained reason I had the experience of weird battery reading with SD card installed and reverting to normal when removed)

If this didn't help,almost certainly hardware related. Time to get the hardware checked and repaired

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.