I'm having this issue with my father's Galaxy Tab 4. He can be just feet from the router and even though the WiFi is strong, the internet keeps dropping on his device.

Even my crappy Dell Venue 8 almost never drops the internet despite the issues it came out with.

I already updated the Galaxy's firmware and didn't fix the issue. I found this is a documented issue in other sites but the samsung link they were giving to troubleshoot this issue was no longer working.

Any help will be greatly appreciated, thanks!

  • This is one of many gripes I have with my Samsung Galaxy Tab 4 7.0. Samsung really cut corners on this device, omitting a lot of features and skimping on hardware. I generally like Samsung devices but have found that they certainly have "grades" of their products. I personally have a Galaxy S3 phone, Galaxy Tab 1, 2 and 4 7" tablets as well as a few other appliances. Basically, anything that is "inexpensive" from Samsung is cheap garbage, while anything that is "expensive" is decent. The Galaxy Tab 4, unfortunately, falls in the "inexpensive" category. – paulmz Dec 9 '15 at 16:13

This is a known issue to users but Samsung won't admit it. I have a Galaxy Tab 4 7.0 and have the same problem. I have read a lot of other users experiencing the same issue.

I emailed, chatted and spoke with Samsung customer service about the issue. After a lot of back-and-forth, I finally set up a service ticket where I sent them my tablet, they replaced the entire motherboard, and sent it back to me. The Wi-Fi is integrated into the motherboard, and replacing the motherboard didn't fix the problem. This is the only device I use that has this issue, and it happens when connected to other networks as well (not just my home router, NETGEAR N600).

Basically, the Wi-Fi in the unit is garbage. The device shows that the device has a wireless connection, shows the SSID of the router, and shows full-strength for the signal- but the internet connection just stops working. No rhyme-or-reason, either. It will happen in the middle of doing something after working perfectly for hours. It normally won't fix itself, and the easiest way I've found to reconnect is to just cycle the Wi-Fi off and then on again.


Actually the Wi-Fi is a good Wi-Fi. Not crappy. I spent over a year and finally found the issue of WiFi turning off.

Try this solution.

In setup go to - more networks → mobile networks and choose connection optimizers and check to remove check mark from box.

In other words where ever your connection optimizers is located. Turn it off. See if this works.

  • The “Optimize Networks” aspect seems the issue. As described above, disabling that option resolved the issue. Thank you for that! – Tiffany Jeanette Price Nov 28 '20 at 23:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.