15

Is there a way to install Google Play app on an Android 6.0 (Marshmallow) AVD? I have found the Open Gapps for Android 6 here: https://www.androidfilehost.com/?fid=24269982087008996

To install them you need to boot into Recovery mode and install that zip file, but an emulator does not have a recovery partition, so the steps target the case of a device.

Do you know, how I can do the same for the emulator? I tried to unzip the file and put the 4 APKs described here (for Android version 5): http://www.flinkd.org/2015/02/instal...i-21-lollipop/

but after rebooting the emulator, although the icon of Google Play appears in the launcher, when I tap on it, then the emulator crashes with some fatal exceptions in logcat. I tried to install the packages one at a time, rebooting the emulator after each installation, and found out that the crash happens after installing the Phonesky.apk no matter if you click on the Google Play icon.

  • Just an idea (untested): Check my app list for Custom Recovery & Flashing. Flashify was one of the apps intended to take-over such tasks from recovery, so one can flash without booting to recovery. Might work in an Emu as well. – Izzy Dec 9 '15 at 18:13
  • Thank you very much for the quick response. I will check it out! :) – Thanasis Petsas Dec 9 '15 at 19:50
  • Don't forget to update us with the results, please! :) – Izzy Dec 9 '15 at 20:23
  • 1
    Maybe the files in the zip contain errors. I will try some other zip files as well I found on other web pages. Logcat doesn't seem to provide enough information about this.. I will let you know. – Thanasis Petsas Dec 10 '15 at 0:03
  • 1
    Did you ever find a working solution? – Irvin H. May 12 '16 at 15:04
7

1) Go get GApps for the emulator from http://opengapps.org

2) Unzip to get

  • GmsCore.apk
  • GoogleServicesFramework.apk
  • GoogleLoginService.apk
  • Phonesky.apk

Launch the emulator from the command line, on linux you do

./emulator [name] -no-boot-anim -writable-system

on windows it's probably

emulator.exe [name] -no-boot-anim -writable-system

Make sure you have adb access to the emulator.

adb remount

last but not least, push everything to system.

adb push GmsCore.apk /system/priv-app/

(and repeat for all the other APKs)

then reboot with

adb shell stop

and

adb shell start
  • 6
    This does not work. This error appears all the time: adb: error: failed to copy 'Phonesky.apk' to '/system/priv-app/Phonesky.apk': Read-only file system. No remount in any way does help, as the output of every remount is the following: mount: Read-only file system. Yeah, thanks android, thats why I want to remount it with rw -.- – CharlyDelta Jul 15 '16 at 19:18
  • In the same boat as @ChristianDreher - can't write to the filesystem. adb remount succeeds, and pushing after that gets a little bit of the way then stops. I can't remount from an adb shell either. Any ideas? – askvictor Aug 1 '16 at 0:21
  • I've had this problem countless times in the past, and it astounds me that the solution isn't more widely known. Simply start the emulator with the -writable-system argument. Hey presto, writable system partition, and these instructions suddenly work. – Adrian May 15 '17 at 7:49
  • 1
    To avoid Read-only file system error you should start an emulator with -writable-system flag – Vadik Jul 4 '17 at 22:42
  • After doing steps in this answer my emulator would not power on. – user1917769 Mar 16 '18 at 15:19

protected by Community Mar 28 '16 at 18:47

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.