14

In my workplace, we have both "real" and "test" wifi connection points. All are password-protected, with passwords that are difficult to remember. Normally I want to be connected to a real wifi, but from time to time, my work requires that I connect to a specific test wifi. I would like to retain the connection information for these test wifi services, including the password, but not auto-connect to them.

With my tablet (running Windows), for each connection listed, there is a checkbox for "auto-connect". I can uncheck that box and retain the information on how to connect, but connect only when I do so manually.

Is there anything equivalent on Android, or is my only choice to write down those passwords, and tell Android to forget the test connections after each time I use them?

Thank you for your attention.

  • Might be doable with a WiFi Priority app – not checked, but worth a try. – Izzy Dec 9 '15 at 23:58
  • You can use an automation app in that case, such as Tasker. Your device would still connect to a Wi-Fi normally, but you can configure the app to disconnect from the Wi-Fi immediately or connect to another if it is in range. – Firelord Dec 10 '15 at 6:17
  • I can just imagine if I used Tasker to disconnect immediately any time I connected to a Test wifi, and my phone sitting there all day connecting and disconnecting, and some poor admin going "WTF? Why is our router going apeshit?" – Topher Dec 11 '15 at 18:38
3

Looks like (if its still relevant) this may be a thing of the past, as manufacturers are implementing this feature in newer android versions a well as builds i.e there is an option to disable wi-fi auto-connect.

AFAIK, this feature comes 'out of box' for Xiaomi (MIUI based) and Samsung Galaxy phones, you can disable wi-fi auto-connection with just a few taps:

  • If have a MIUI based device, navigate to WLAN settings → Tap the right arrow besides the wi-fi SSID name then toggle to disable the 'Auto connect' feature:

IMG:

  • If you are on Samsung device you can control the “Auto reconnect” feature from

wi-fi ssid name (long tap) → Manager Network Settings → Uncheck “Auto reconnect”.

enter image description here

(Image credits)


Nevertheless if you can't find this feature on your device, there is another workaround:

You have to install, an additional third-party application called WiFi Prioritizer (which seems to be working after trying dozens of related ones. Note I am not affiliated with this app or developer)

WiFi Prioritizer aims to solve a simple problem by attempting to automatically reconnect to a higher priority wireless network when it comes in range while still being connected to a lower priority wireless network.

Workthrough

  • After installation open the WiFi Prioritizer app, toggle the Enable Scheduled Job switch to On.
  • The Access Point list contains all your saved Wi-Fi networks. Here, you'd have to set the priority of the networks. Start off by dragging your preferred connections to the top. From the problem onset you may want to leave out "test" connection.
  • You may optionally set signal threshold (in case you have multiple defined APs apart from the test. As long as the job is running you are assured the device wont connect to test AP as its not included in AP priorities.

You may also want to take a look at WiFi Manager (again I am not affiliated with it).

Hope this helps

Credits

How to Prioritize Wi-Fi Networks on Your Android Phone

| improve this answer | |
  • 1
    Thank you for this thorough reply. Unfortunately older phones (mine is a Galaxy Note 3) will not update to these newer versions of Android, so I'll have to try this app. – Topher Nov 16 '18 at 19:34
1

I have a Sony Xperia Z2 and this auto-connect to WiFi has been driving me up the wall for months, and the Z2 doesn't seem to have the setting to switch off auto-reconnect, but tonight I finally found out how to stop it:

The answer:

Go to Settings, tap WiFi. It will turn itself on, ignore that for now.

Tap the three dots menu top right, and tap "Saved Networks". This can only be done while wifi is on, it's greyed out otherwise.

For each saved network, long-tap it, a pop-up appears with an "auto connect" tickbox, pre-ticked. Untick the box. This should put an end to random wifi reconnects.

Background:

On the Z2 I have a VoIP app that connects to an Asterisk PBX inside a company VPN, via which I can receive Support calls. I also have 20 gig of 4G data a month, so no need to try and economise via wifi. So at home I'd turn wifi off from the top bar, connect to the VPN over 4G, and fire up my VoIP client to receive calls. And then after some random period of time the phone would decide to auto re-connect to wifi, breaking the VPN connection and disconnecting the VoIP. However the wifi signal in my workspace is very weak (router on ground floor, workspace in the attic - main PCs are on a wired network), so as soon as it had connected it'd drop off again. Plus all the random turning back on after I'd turned it off would waste battery power - if I turn a thing off I expect it to stay off. I came close to throwing the phone a few times.

I've googled this issue many times but all the threads on various forums referred to settings and apps that do not exist on my phone. Found the solution I've detailed above by chance this evening while out of desperation trying every conceivable option and tap-type. Given the number of frustrated users I saw on various threads, I hope this answer is of use to other people in the future.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.