So, I recently bricked my A7000. Found a rom somewhere online and flashed it with SPTools. Now it boots fine but I get the "INVALID IMEI" error.

I rooted it gain, got into engineer mode with MTK Engineering Mode and run the command AT +EGMR=1,7,"blabla" but it's still not working. I get AT command is sent: ERROR

Please help...

  • 1
    I had this issue once. Perhaps, my answer may help: How to fix "Invalid IMEI " after Factory reset? – Firelord Dec 10 '15 at 10:45
  • @Firelord You mean method #2? Method 1# is exactly what i did to get here.. – user1824034 Dec 10 '15 at 10:52
  • Consider following both the methods and tell us the results. – Firelord Dec 10 '15 at 10:53
  • @Firelord The first one did nothing. For the second, Maui can't detect the phone, it says "[36] BootROM start command passed, but target has no response untill timeout.." the phone displays some chinese characters and says it is in meta mode (with verry bad grammar). – user1824034 Dec 10 '15 at 11:48
  • Did you try using mtk droid tool ? – lord-ralf-adolf Dec 10 '15 at 11:56

Solved it. I rooted with SPTools and used Chamelephon to enter the IMEI's (if you have dual sim, enter both at the same time!).

Not the answer you're looking for? Browse other questions tagged or ask your own question.