I have a Galaxy SIII (Android 4.3) phone on the Vodafone network (UK). I was using WiFi when available and mobile data occasionally. It all worked fine. When on mobile data, I would see an icon on the top bar showing a little letter H with two arrows underneath.

But now the mobile data has sort-of stopped working. I say sort of because it appears that I can still turn mobile data on, and I still get the little H with two arrows, but none of my apps that use data appear to actually be able to communicate with the internet. I don't actually get any "no connection" messages, instead, I just get rotating wheels and other indicators that they're trying to get something that's not arriving.

If I switch back to wifi then everything starts working again.

Any ideas?

EDIT: I have not installed any custom ROM. The phone is not rooted.

EDIT: I just called vodafone, who suggested a variety of things that made no difference. Now they've said it may be a fault in my SIM card and are sending me a new one.

EDIT: New sim card arrived. No difference. More calls to vodafone, multiple suggestions... nothing has worked.

EDIT: Tried sim in Galaxy SII... all symptoms identical. Saw little H icon (sometimes flipping to "H+" or "3G"), but no mobile data getting through.

SOLVED! it suddenly started working again. I suspect it was a fault at vodafone's end and my last call to tech support induced someone there to correct the fault.

  • Have you installed a custom ROM? Commented Dec 11, 2015 at 9:32
  • If APNs is changed then this kind of prblm will come. Make sure you enabled your carieer(vodafone) related APNs. If you added new or wrong APNs and enable that it will show an "H" but you cannot access internet. Commented Dec 11, 2015 at 11:51
  • 1
    @Mick did you tried to contact vodafone customer care regarding this issue. They can easily tell about APNs changes. Commented Dec 11, 2015 at 12:21
  • 2
    @Firelord: Fing said "Not connected to a WiFi network". Terminal reported "operation not permitted". Typing that sequence into dialler then pressing the green phone icon did nothing. :-(
    – Mick
    Commented Dec 14, 2015 at 14:31
  • 1
    Did Vodaphone recently update the cell towers? It's possible (although not likely) that they updated their towers to radio bands that your phone can't use.
    – sonictt1
    Commented Dec 16, 2015 at 22:47

2 Answers 2


TLDR: use a SIM with a different number (no matter if Vodafone or a different service).

We see a symptom (no net), but we have to find out the cause first, to solve the problem. So let's think step by step, what the problem could be.

  • Faulty phone?
  • No, your other phone (the SII) doesn't work either (using the same SIM).*

  • Faulty SIM?

  • No, you have already tried a new SIM.

  • Faulty cellular tower?

  • No, you have already tried an other tower (by changing location).

  • Faulty Vodafone?

  • Likely, because I'm sure they have net, and you're sure that they have to give you net (data limit hadn't been reached), plus we've found out in the previous questions that it isn't about the net is stuck between you and them. The only problem here is that you have already asked them, so they should have investigated the issue. But I'm sure they will take a next - more in-depth - look, since all the other possibilites are crossed out now.

I advise you to call Vodafone again, tell them that your phone is ok, your SIM is ok, the local tower is ok, your data subscription is ok, and then there is nothing left to do: they have to accept the fact that there is something wrong with their service. Until that, use a SIM with a different number, I'm sure it'll work in your current phone.

* To be 100% that your phone is ok, try a different SIM with a different number. I think the new number can still be Vodafone, because only your current account is affected (your current number), not the whole infrastructure. However, if you don't want to experiment (and your phone is unlocked), you can immediately get a SIM from an other company, as Firelord suggested in a comment below. (So that you are safe, even if the whole Vodafone system is damaged.)

  • 1
    Plan is not over. Tried in multiple areas. Tried "WCDMA only". No difference.
    – Mick
    Commented Dec 17, 2015 at 13:48
  • WCDMA is 3G. Choose 2G instead (GSM only). Commented Dec 17, 2015 at 15:53
  • 1
    If I set "GSM only" then I have all the same problems... except I see a "G" instead of an "H" in the notifications bar.
    – Mick
    Commented Dec 17, 2015 at 17:22
  • I suppose your phone is okay, since the SII produced the same problem using the same SIM. But the SIM can't be the problem either, because you have already changed it. So my next guess would be the tower, but you have already tried in different locations. So it must be a service problem, like Vodafone has accidentaly disabled your data access etc. Prove them your phone is ok, your SIM is ok, the local tower is ok, your data subscription is ok, and then there is nothing left to do: they have to accept the fact that there is something wrong with their service. Until that, use a different number. Commented Dec 17, 2015 at 17:58
  • May I suggest, at the bottom, you change "try a different SIM with a different number" to "try a different SIM with a different network". I believe this is what you actually meant because you've already mentioned that OP tried a new SIM of same number so suggesting a different SIM wouldn't help. Suggesting another number may not help either if it is not mentioned explicitly whether to be of same network or other. It's just to remove confusion. Just a suggestion. Nothing more. :)
    – Firelord
    Commented Dec 19, 2015 at 18:02

If you've not considered, put a new SIM card into your phone and if it works, then the network is messing up. It might sound impossible but your network is likely messing up.

Try a different network. If it works, then Vodafone's network is the culprit.

  • He has already tried a new SIM, it didn't help. I guess it was a Vodafone SIM with the same number that he had before. So I see two options: either the whole Vodafone network is wrong, or only the account (number) of Mick. In case one, I suppose Vodafone has already received a lot of reports, so case two is more likely. If so, changing the SIM to a different Vodafone SIM (having a different number, independent from Mick's account) should be enough. Commented Dec 19, 2015 at 22:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .