I have a Galaxy S5 Verizon.

Starting today, my wifi on my device has been acting stupid.

Whenever I try to browse the internet, it lags. It isnt an issue with my internet or my router. Because when I run a speedtest on my cellphone, it will take a minute to start but when it does start, i get 11 ms ping 60 down 10 up.

Same with a wired connection on my desktop. Same on my galaxy tab 12.2.

I noticed that when I use wifi on my phone, the wifi download icon is active, but the upload icon isnt. Meaning when I use wifi to browse the net, its able to download data using wifi but it stalls trying to uploading data.

Well because of this, instead of having my normal instant speeds, I have lag. It takes a while for a youtube video to load. It takes a while for a web page to load. WHen i used the app store it took a while for the app images to download and it took a while for an app download to initalize.

I dont know why this is happening. All I know is that for some reason my device is failing to upload data using wifi right away. It always stalls.

Like I said, this just started happening today too.

I didnt do much on my device. The only thing that could possibly have done something is that I used terminal to change my device hostname. I was tired of seeing "android-3478547583gf7348574835" On my router arp table. So I went onto terminal and I did

> su
> getprop net.hostname
> setprop net.hostname <new_hostname>

And then I went onto recovery and wiped my cache.

Thats the only "Technical" thing I've done with my phone today and now for some reason my wifi stalls.

Any ideas?

I wiped the cache again to see if that would fix it. Didnt. Rebooted my phone dozens of times. Did nothing. I dont want to resort to factory resetting but I will if I have to. Im rooted. GS5 on 5.1.1

edit: I shouldnt say its a lag issue since I still get 60 mb download speeds. Its just an initialization issue with my wifi

  • I'm not the big networking specialist, so I'm afraid I have no final solution for you. But maybe a tool for network diagnosis can help you finding the issue? I've heard Fing praised often. Maybe worth a try.
    – Izzy
    Dec 13, 2015 at 11:18
  • Having used Fing, it really doesn't offer a tool that can help in his situation. unfortunately. Dec 13, 2015 at 17:54

1 Answer 1


If changing the hostname appeared to cause an issue, perhaps changing it back might solve the problem? Worth a shot.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .