12

Is there a way of disabling auto-play of video in Chrome? Many sites have moved to HTML5 video and so you have ads or featured videos that start automatically playing the moment the page loads.

8

On Android Chrome 54, turn off autoplay of media by going to Settings - Site Settings - Media - Autoplay and Block autoplay.

This feature is disabled if you have data compression enabled in your Android Chrome browser.

4

Starting from Chrome 47, there's a Chrome flag that is used to turn media autoplay on/off:

Disable gesture requirement for media playback.

Disable user gesture requirement for playing media elements. Activating this will allow autoplay to work.

You can see it by going to this link: chrome://flags/#disable-gesture-requirement-for-media-playback;

The default status for the flag is disabled, so autoplay should not work: you should check your Chrome version and eventually update it. I tested with version 47 and autoplay does not work unless you turn on the flag.

Other info here.

  • It's for background tabs, not the current tab. – CadentOrange Dec 16 '15 at 16:18
  • 1
    I tested again right now and it works also in the foreground tab in Chrome 47... Have you tested it? Could you share the link you tried? – dipanda Dec 16 '15 at 16:44
  • Try visiting this page. The ad on there autoplays and the speaker icon appears in my notification bar. – CadentOrange Dec 18 '15 at 14:14
  • I've just tried this on a variety of pages - in particular smh.com.au - and it appears to block the playback on all videos, thankfully. That said, contrary to the OP, it was Disabled initially and I had to Enable it to disable the auto-playback. The description states "User gesture requirement for playing media elements. Disabling this will allow auto-play to work". – Mike Sep 15 '16 at 4:56
2

Chrome for Android doesn't have an option to disable autoplay. My solution is: Switch to Firefox.

Not the answer you're looking for? Browse other questions tagged or ask your own question.