I am facing a weird scenario in my android phone since 2-3 days.

My wi-fi is automatically getting turned off and my mobile data pack is getting turned on.

It has been cost effective 2-3 days.

I have followed different questions on Android forum and stackexchange it self.

I am listing out the suggestions, i have already tried:-

  1. Disable battery saver app (I dont have any battery saver app installed)
  2. Did restrict background data for each and every app installed on my phone (As many blogs were suggesting the same)

Still am facing this issue.

Model-Micromax A310 Android Version - 4.4.2


1 Answer 1


There is an option in the Wi-Fi settings: Keep Wi-Fi on during sleep

It has the following options: -> Always -> Only when plugged in -> Never

Make sure the above is set to "Always". I believe it will have set "Never" in your case.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .