0

My phone is currently stuck in a boot loop. I tried using minimal adb and fastboot but I can't seem to do it. I have also read in some forums that usb debugging should be enable and the phone should be rooted. Is there a way to use adb commands without enabling the usb debugging('coz I can't). I tried all the choices in the recovery mode except the factory reset. Can somebody help me? I really need to recover the memos that I have saved. I have a Samsung galaxy V duos. Thanks. I'm also new to adb :(

  • 1
    are you using stock recovery or custom? – user138468 Dec 17 '15 at 13:41
0

Is there a way to use adb commands without enabling the [USB] debugging[?]

There is no point pondering about this once you understand the concept. In order to communicate with device using you need to have adb daemon running at Android's end. Additionally, for successful communication, you may also be required to authorize debugging at Android's end.

Android starts the adb daemon only when it finds the USB debugging setting under Developer options enabled. If it was enabled but was explicitly disabled by a user, the daemon would be stopped. It would be started again by Android should the setting be toggled.

If you've an another device with a terminal app installed and USB debugging enabled, do

ps | grep "adbd" 

You would see an output similar to

shell     161   1     4564   284   ffffffff 00000000 S /sbin/adbd

(shell is the group name with ID 2000. This is the same ID that you would see when you get a successful shell session using adb shell.)

Disable the debugging option and the daemon would be stopped by Android. Use the same ps command with grep and it would give you nothing.


As for recovering the data in this situation, keep any hope as long as you've a custom installed. They often always run adb daemon without any complexity of authorization from user. Then you can use adb pull to copy whatsoever data you want.


Related reading: Android Debug Bridge

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.