1

A month ago, i used Kingroot to root my Sony Xperia Z1 running lollipop . Today, my dad called me on the phone and i picked up. 5 minutes later, the phone will not boot up. I thought that the battery is dead and tried to charge the phone using the original wall plug.

The phone will not charge or boot up. It will show red blinking on my phone. I highly doubt that my phone has no battery at all because it is 40% when i last used it to call my dad.

Also i have tried to power on the phone by pressing the on and power down/up button but it does not work. I have tried to reset the phone by pressing the small red button at the micro sim slot but is also does not work.

I have also tried to use the Sony PC Companion but it does not detect my phone after i have download the installation for the update. I have also tried using Emma but it did not detect my phone at all.

Now what i know is that my warranty is void because i rooted my phone and they are going to charge me to fix it. And before i send it down to repair, i would like to know what else can i do to boot up my phone.

Thank You

Jun Run

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.