7

After updating to 6.0.1 (MMB29K) from 6.0.0 (MRA58R) I have come to face a very odd and never seen before issue. My battery stats are wildly wrong. My stats show 4k% or higher and no battery stat monitor, such as the system battery monitor or GSAM for example can see anything correctly.

Here is an image of what the battery stat shows:

enter image description here

Here is the power manager:

enter image description here

Has anyone encountered this issue and if so what's causing this? I have not found anything so far that would explain it. Although I have not yet had a chance to fully comb the source code of the latest release, I don't suspect they would release it with such a glaring issue, so I am wondering how it has come to be.

Some FYI, Its a Nexus 6 device, fully rooted and not that its relevant but also fully encrypted. Anything else you wish to know, let me know. The apps and configurations have been the same on this device (+/- occasional test app that is usually removed within a day or so) since its stock 5.0 OS (which was unlocked and rooted immediately upon receipt).

UPDATE: 12/20/15

I want to begin with many thanks to @beeshyams to offering assistance and providing possibilities to consider. Although the problem was not entirely covered by our discussion, I did figure out what the issue was because of the decision we made to reflash the boot.img and that revealed the problem. Short version, reflashed the stock 6.0.1 boot.img and it resolved the issue. Long version, read below:

TL/DR/RL

The systemless method by which the boot is being done beginning with M (6.0) was to use the SuperSU zip update to root the system without actually modifying the system partition, making for a potentially cleaner or if you will less hacky way of getting root than in the past using the system exploit. Feel free to follow the process by @chainfire here: [WIP][2015.12.20] Android 6.0 Marshmallow [v2.64] but simply put it would use a modified boot.img and a special version of the SuperSU and achieve the root. However as the project gained momentum and new methodology was tested, it was decided in favor of abandoning the use of the modified boot.img and allowing the improved SuperSU binary to handle the internally required modifications. I had forgotten to change the batch file I use to automate the process to remove the patching of the modified boot on top of the stock boot and that's in simplified term what caused the issue. I reverted the boot to the stock and applied the SuperSu binary again to modify the stock properly and it fixed the issue. Thank you for everyone's attention and I hope that this will help others in some way.

3

I would start by holding all three physical buttons for a full 3 minutes (phone switched off) to fix battery logic problem. This resets the battery logic on some phones and how the battery talks to the software to let it know how much power it has and other parameters. Service center may be able to help you with exact procedure for your phone (please share their recommendation so that can help others)

Few possibilities if above didn't help:

  1. Battery houses the chip that communicates state of battery to device including charge levels, temperature etc. That could be bad, though your phone is new, being a defective piece. Can be checked by replacing battery

  2. Fuel Gauge drivers in OS corrupted. After backing up data,reflash stock to rule out this possibility. Also eliminates rogue app possibility, though app mischief not likely on your case

  3. Problem with hardware (Fuel Gauge chip). Unlikely but possible

Edit

Further to our discussion, saw this on Nexus forum, which sends to have worked for most, though none reported your problem https://productforums.google.com/forum/m/#!topic/nexus/D7er7nMbzHI

1.Power off your phone. 2"Press and hold the Power and Volume Down buttons. This will put the phone in fastboot. 3.Use the Volume buttons to scroll through the menu until you see "Bootloader logs" 4.Press and hold the power key for a long time (7+ seconds) until the phone reboots.

3 button procedure described in my answer as first option is more elaborately covered here http://forums.androidcentral.com/verizon-htc-one/394469-battery-charger-reset-procedure-htc-one-m7-m8.html

Let me know which works...

  • Thank you for the suggestions. #2 this is a fresh flash of the new ROM image, so that takes care of that, hence my surprise. #1, #3, not saying not possible but to have it happen immediately after the update only, that seems a bit too coincidental of a timing, no? I will try the 3 button reset, I need to figure out how to do it so the device stops turning on :) – GµårÐïåñ Dec 18 '15 at 7:32
  • Thank you for the extra information, I appreciate that. I am sorry for the delay reporting back, I have been engaged in trying a number of things. I rolled back to the previous version and sure enough the problem disappeared but imaged back to the new one and BAM its back. I have tried several of the solutions and so far no luck. The fastboot reset method did nothing, I used terminal to remove the batterystats.bin (a shot in the dark really) but to no avail, I have tried just about everything, this is very very puzzling. – GµårÐïåñ Dec 18 '15 at 20:02
  • I know, the deleting of batterstats.bin as I said was just a shot in the dark, not something I considered a real solution but when you have no solution present, you try what is harmless just to cover all the bases :) – GµårÐïåñ Dec 19 '15 at 1:34
  • Ok I understand. Just to be clear, you want me to only roll back the boot.image right? To test the theory we are referring to? If I understand correct and please correct me if I haven't, I will use the previous boot image along with the new system image? Is that the combination you mean? Because you are right, something is going screwy somewhere and given the roll back "fixes" the issue, it has to be something in the new image, I will reach out to the developer team too and see if they know what's up. I am waiting to hear back but maybe I need to poke a bit more. – GµårÐïåñ Dec 19 '15 at 1:38
  • 1
    Appreciate it, thank you. I also DID upvote :) – GµårÐïåñ Dec 21 '15 at 23:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.