1

Since upgrading my Samsung Galaxy Xcover 3 phone to Android 5.1 Lollipop, I've noticed that the flashlight keeps getting turned on in my pocket. Apparently, pressing the "Xcover button" on the side of the phone will now toggle the flashlight on and off even in the lock screen.

I've tried to find some way to turn this behavior off, but I'm not seeing anything in the settings that would look promising. My attemps to Google for a solution just yield instructions for enabling flaslight access from the lock screen on versions prior to Lollipop.

Short of getting a more robust case for my phone, how can I keep my pockets from shining in the dark?

1

I had this same problem, and found a solution!

Download a random app (one that you don't actually need) from Play Store, then go to Settings (Personal / Xcover key) and change the button to open that app. Test that it works, and then delete the app, and now the button does nothing. ;)

  • Good idea! The only problem is that this also disables the button when the phone is unlocked, which is not ideal, but I guess I can just add the flashlight app to my home screen instead. I did some testing, though, and it seems that if I bind the button to some random game, it will not launch from the lock screen -- it seems that the real problem (to me) is that the built-in flashlight app has some permission that lets it bypass the screen lock. So I think if I found a third-party flashlight app with fewer permissions, and bound the button to that, it should work the way I want it... – Ilmari Karonen Mar 2 '16 at 15:50
2

Today my girlfriend's father ask me how to solve it.
I've just written an lightweight app (7kB) which does nothing at all.

Download it from here and set as your XCover button app :)

  • the app should be available within 2 hours from now... – klimat Sep 26 '16 at 20:39
  • That's... awesome! :D – Ilmari Karonen Sep 26 '16 at 21:49
0

I have found that this will disable the torch: Go to SETTINGS then ACTIVE KEY press SHORT PRESS and select NO ACTION, this should now disable the torch but leave the camera active on a long press.

  • I don't see that option on my XCover 3 (Android 5.1.1). Also (possibly related), on my phone the settings item is called "Xcover key", not "Active key". – Ilmari Karonen Mar 14 '17 at 16:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.