1

Before I start, no this is not a duplicate of this question. They just happen to have similar titles.

Anyway, I wanted to listen to music on my Moto X smartphone. So like I have always done with every MP3 player and old phone I've had in the past, I just connected the phone to my computer with a USB cord, and then used Windows Media Player to sync the music files to the phone.

As far as I can tell, Google Play Music is the only app on the phone that allows you to play music files. So I opened the app up and set it to "Downloaded Only" in the sidebar menu. Then I went to "My Library," but to my surprise many of my songs weren't there!

With the phone hooked up to the computer I can look in the Moto X's "Music" folder, and all my songs that I synced are there. But inexplicably some albums don't show up in the Google Play Music app. Can anyone tell me why this is and/or how to get it so I can play these files? Thanks!

  • What format are those files? Check developer.android.com/guide/appendix/media-formats.html to see if your codecs are supported. WMA (Windows Media Audio) is NOT supported. – GiantTree Dec 21 '15 at 21:25
  • @GiantTree Oh no, searching through the ones that come through and the ones that don't, it looks like they ARE Windows Media Audio files... Oh dear, please don't tell me this means that I'll have to convert them all to different file types before transferring them to my phone.. – Guy Dec 21 '15 at 21:28
  • If you don't use a player that features a custom decoder like PowerAMP, you need to convert them to another format, preferably MP3. – GiantTree Dec 21 '15 at 21:31
  • @GiantTree Uhg, okay. I'll see if I can't find a way to make Windows save ripped CD files as a different default file type that isn't WMA. You can put your comment in an answer and I'll give you credit if you like. – Guy Dec 21 '15 at 21:34
2

Android does not support many formats by its MediaPlayer library.
Check http://developer.android.com/guide/appendix/media-formats.html to see if your codecs are supported.

If you don't use a player that features a custom decoder like PowerAMP‌​, you need to convert them to another format, preferably MP3 or FLAC if they are lossless.

Windows Media Player does have a way to change the default Media Copy format:

  1. Go to Organize->Options
  2. Switch to the Copy Music tab
  3. Select the format you'd like from the drop-down list.
  4. Select your preferred quality setting (in kBit/s, I recommend 256 kBit/s, because 320 kBit/s does not really add more quality for the bigger size)
  5. Hit OK
  6. Copy all the music!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.