2

I have always run the nightly cyanogenmod builds as I've never found any major bugs. My device was rooted when running CM12, and since, I've received an update to CM13 through the inbuilt updater. However, I have noticed that since updating, I cannot get root access and have tried (multiple times/ways) to reroot my device, and I have not been able to.

Should I be able to root my device, or is this some feature of CM13 that I am as of yet unaware of?

If you want build.prop or any other information, please just ask. Thanks!

PS. The methods I've tried:

EDIT: Yes, I've enabled root access in Developer Options (to both apps and ADB) and yet when apps request root access, no dialog shows up and they just fail. I've tried root checkers, I tried to install CWM using the app rather than flashing through fastboot... Neither worked.

  • 2
    Have you gone into your settings and enabled root access? It has changed in CM13. It should be in the developer settings now, I believe, but there is no longer a Superuser application. It's all integrated into their permission management system. – eldarerathis Dec 22 '15 at 16:17
  • 1
    I agree with eldarerathis. I recently tested a CM 13.0 build and that was the way to go for root access. – Firelord Dec 22 '15 at 16:23
  • This is weird.. Did you try flashing SuperSU.zip from custom recovery like Philz or CWM or TWRP?? That should really work. I don't think we need a customized boot image for rooting CM13. – Gokul NC Dec 24 '15 at 14:20
  • No... I'll try it, thanks. And the boot image was to make the su executable, I'm pretty sure. It didn't overwrite my boot image, I just booted off it once (as per the instructions). – TheAbelo2 Dec 25 '15 at 19:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.