0

Bricked my phone trying to install Cyanogenmod on it. Formatted every partition, including /boot and /recovery.

The phone can't:

  • Boot into home screen.
  • Be reached by ADB.
  • Have it's bootloader rebooted.
  • Flash a new recovery.

The phone can:

  • Get stuck in a boot loop.
  • Enter ZUK Recovery.
  • Enter Download Mode.

Additionally, using adb to look for devices while the phone is in Download Mode returns this:

????????????    no permissions

Any idea on how to solve this? Or am I stuck with a brick from now on?

1

Yesterday we ended up in the same state after trying to flash CyanogenMod 13 on the phone: loop trying to boot CyanogenMod 13 (cyan robot head with circle waves) and no way to get the phone to put itself into adb or fastboot mode.

Here's how we solved the issue and got the phone working again, just if it's useful for somebody in the future:

  1. Reboot to the (factory) Zuk recovery firmware: press VolumeUp+VolumeDown+Power continuously. The phone will reboot (keep pressing). Unplug the phone USB cable. Choose "English" and then "Power off". Let it power off.

  2. Get TWRP from twrp.me. Try to flash it using fastboot with the USB cable disconnected (it will wait until you connect the cable, don't do it yet, let it wait):

    fastboot -i 0x2b4c flash recovery twrp-3.0.2-0-Z1.img
    
  3. With the phone switched off, press VolumeUp+VolumeDown (not Power) and plug the phone to the computer with the buttons pressed. This was the magic required to put the phone in fastboot mode. Fastboot will do its job and TWRP will be flashed. It worked for us, but this flashing step might fail for you. Only if it failed, what I would do would be to return to step 1 and try to boot directly from TWRP like this, and then go to step 5:

    fastboot -i 0x2b4c boot twrp-3.0.2-0-Z1.img
    
  4. To boot the phone into TWRP, press VolumeUp+Power until the phone reboots (keep pressing until TWRP boots).

  5. To get the phone to a working state, flash CyanoGen OS 12 (this archive) once TWRP is loaded:

    adb push cm-12.1-YOG4PAS7DF-ham-signed-c4eecafcd7.zip /sdcard/
    

On TWRP: "update", select the zip file you copied with the previous command.

Reboot, and you have a working phone again.

Thanks a lot to Gonzaman for the "Poweroff your device hold vol+ and vol- and connect it to pc" trick. You saved our day! :-)

  • sir(eocanha) i too got same problem, I've followed all of your steps all went fine but ended with Boot Loop Again waiting 4 ur reply soon – Er. Harsha Bhat Aug 22 '16 at 14:47

protected by Community Nov 30 '17 at 4:47

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.