7

I'm trying to connect my 2014 Macbook pro to a Pixel C tablet. The tablet has developer settings enabled, usb debugging enabled and unknown sources enabled. 'adb devices' shows nothing and there is no debug icon shown on the tablet.

I'm using a usb 3 type C connector that works Perfectly from my Macbook to my Nexus 5x

I've tried resetting the PRAM/NVRAM and the SMC to no avail.

The strangest thing is that we have 3 developers here with 2 ports per macbook. It does work on ONLY 1 port on one macbook, a 2015. We have a second exact same macbook bought on the same day that this tablet doesn't work on either.

Since it works on 1 port on one macbook, we know that the tablet is configured correctly for debugging. But why can't we connect it to the second port on the same machine or to another macbook??

We've never had any issues connecting any other Android device to any of these macbooks before.

Updates:

  1. Got a different usb C cable and still have same issue.
  2. Default USB Configuration (from Dev Options) is MTP, tried other USB config PTP and didn't help
  3. After testing again on the 1 port that it worked in the past, trying 'adb devices' shows the Pixel C about 3 out of 5 times (in the span of 10 seconds). Trying to deploy to the device fails every time, presumably due to the flakey connection...
  • Is it plugged in to a USB 2.0 port? I have had issues similar to this when I plugged it into the Apple keyboard rather than the built-in ports of my MBP – TheBro21 Dec 23 '15 at 23:48
  • 1
    @TheBro21, I checked and all the usb ports on the 2014 and 2015 macbook pros are usb 3.0 – aaronvargas Dec 24 '15 at 0:01
  • 1
    @TheBro21, OS X doesn't require ADB drivers. Please refer Google's official documentation. – Tamoghna Chowdhury Dec 24 '15 at 4:31
  • 1
    @Firelord , you very well understand what I mean. A computer can recognize and operate the ADB protocol with a device if it has a driver for the device which exposes the ADB interface to the device over USB. That's what we refer to when we say ADB drivers. TheBro21 refers to Heimdall as requiring a kext (kernel extension, an OS X term for drivers, among other things), which is Samsung specific, and completely N/A for the OP who has a Pixel C (which was released in 2015,BTW) with Tegra X1 hardware, nothing Samsung specific at all, hence nothing Heimdall/ODIN-related is applicable here. – Tamoghna Chowdhury Jan 13 '16 at 7:13
  • 1
    @TheBro21, I don't get any output from the ls /dev/ | grep usb command you provided, either with or without the Pixel C connected. But... when I plug in the Nexus5x with a USB type C, even though adb devices shows it, the ls /dev/ | grep usb command given doesn't show any output either. I also tried it with only a Nexus 9 (standard usb) connected, and adb shows the device, but nothing from the ls command. – aaronvargas Jan 15 '16 at 2:19
3

I have tried a number of USB 3.0 cables with no luck but every high quality USB 2.0 cable I've tried has worked for me. This includes USB 2.0 cables that have a Type C connector (There are many of these on Amazon. I'm currently using an "iOrange" brand cord) as well as traditional micro-usb cables with a Type C adapter ("TechMatte USB-C to Micro USB Adapter").

I'd prefer faster charging and better speeds but this takes care of my debugging needs reliably.

  • Ok, I've got my order on the way from amazon.com/iOrange-E-Braided-Reversible-Connector-ChromeBook/dp/…. I hope this works @goto10! Otherwise, if you're just trying to get me to order your product from Amazon... nicely played. Also, nice Google Glass picture Playa! – aaronvargas Feb 13 '16 at 4:42
  • You're right! Tried 2 different USB 3 cables and they didn't work, (although they both work on my Nexus5x) but the USB 2 that you recommended worked perfectly! I wish I could have given you the bounty that I had on here a while back, it went unclaimed. – aaronvargas Feb 19 '16 at 3:06
2

Unfortunately, I've found that rebooting the mac will cause the adb to recognize phones through the usb-c, even if I later unplug and plug it in again. Eventually, something happens and it stops working until I reboot.

  • This was my situation too. I have the cable mentioned in the other post, which has always seemed temperamental, but restarting solved it for me this time – head in the codes Oct 1 '18 at 3:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.