Just got a fossil Q Founder smartwatch. How do I change the default weather app to use Celsius? Currently it is showing Fahrenheit. I've changed literally every single setting I can think of. I have used the fossil app to change the watch faces to show temperature in celsius. I have google now cards configured to show celsius. I even tried downloading the Google News and Weather app and changing the temperature units used there. I checked every settings menu I could find in both the android wear app and the fossil app. Nothing.

Rocking a nexus 6p. Everything is the latest.

Multiple google search results have pointed to Google Now weather card settings as the place to change the units in the android wear app, but as I mentioned above I already have those set since before I even had the watch. I tried changing to fahrenheit and back to celsius, but still no luck. I've tried restarting the watch and my phone a million times, but also no luck getting the settings to take on my watch.

Can someone please help? It doesn't help that google has the worst support imaginable. I would bet my life savings that if I called them for support they would tell me to do a factory reset without even attempting to understand that actual issue.

  • Nothing was working as a lot of things are updated now. I followed the following video it did the trick for me. [ CHANGE TO FAHRENHEIT or CELSIUS in Accuweather App](youtube.com/watch?v=ivjyvdambOY) Jul 8, 2020 at 20:03

7 Answers 7


I contacted Fossil who said that the temperature units on the watch are based on the language setting you select when you set up the watch. If you select US English, then it will be Fahrenheit (probably the only language setting that uses Fahrenheit).

I am Canadian and there is not usually a Canadian English option and UK English has caused strange anomalies for me in the past. Plus I live in the USA, I just want Celsius and I don't think I'm the only one. I informed them that their solution for units is not adequate.

I will edit this answer if they get back to me with anything more useful or if they fix the issue and make it configurable.

I am using the accuweather app which I paid for years ago and I like it. But their android wear app is broken right now on my watch and they are aware of the issue and working on it, but it has been some time (plus their latest material design update took ALL of their flexibility out of unit selection so that is quickly becoming an issue).

  • I can always tell when google has a regression and re-introduces this bug because it suddenly starts getting upvoted again. Maybe someone should tell google about regression testing, either way can't say I'm surprised to see google is still not doing a good job at anything.
    – gnomed
    Mar 31, 2021 at 19:07

It's because of your phone language is set to US English.

Just change your handphone language to other type of English such as English (United Kingdom), then the weather in your watch will change to Celsius.


I just bought a Fossil Q Founder watch.

If you go to watch setting, then change watch face, scroll to classic, tap the setting bar below the displayed face, then it will allow you to scroll down to weather unit. Tap it and it will allow you to change between Celsius and Fahrenheit.

  • That is correct, but only changes it for the watch face. I was trying to adjust it for the built in weather application. Unfortunately I just arranged for a return and refund on my fossil Q founder. Turns out if the watch is exposed to any moisture, dust, or sand, the warranty is voided, which kind of makes the whole IP67 rating completely useless. I recommend others do the same to be honest.
    – gnomed
    Mar 30, 2016 at 18:29

If you're using a face control app (WatchMaker, Facer, Etc.) you may have to go into the settings for that and change it. I use a ton of WatchMaker faces and I was losing my mind changing languages and Google now settings, until I saw the settings in the app.


Here is how you change it:

  1. log in to your google account on your computer
  2. GO to https://myaccount.google.com/u/1/language
  3. Change your language preference default to English and then choose Canada.
  4. Make sure you use the same account for google wear OS.
  5. If you are using the same account, after thischange restart your fossil watch and you should be good to go.

I have tested this on Fossil Gen 5 and it works.


I had the same issue with my Fossil Sport watch. I live in Canada and it showed as Fahrenheit. When I setup the phone it did not give an English (Canada) option, so I picked English (United States). I found a solution though. I updated my language setting on my phone through Settings, System, Languages and inputs, Languages. I had English (United States) as my default language and English (Canada) as my second language. I deleted English (United States) and that changed English (Canada) as my default. Once I did that, my phone immediately updated with Celsius. 😁



Go tu your android wear app Your feed Weather Change temperature to celcius 😜

  • Maybe you can add screenshots or provide more detailed steps to change the temperature units. Currently the answer is very short and too generic.
    – GiantTree
    May 9, 2017 at 18:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .