1

My phone fails to connect to wifi networks it has been connected to before. When this happens, even if I reenter the password it will not connect. But if I restart the device, it connects to the network without my having to enter the password. This happens both at work and at home. It's a Samsung Galaxy Stardust running Android 4.3.


I don't know if this is an answer, but my problem has gone away. Here's what happened. I called TracFone tech support about this. The representative told me to shut the phone off, pull out the battery, and see if the battery had a red sticker on it. It didn't. Then she told me to put the battery back, and that the next step would be to do a hard reset. When I found that doing so would erase my settings and contacts and such, I declined. So I thought I had wasted my time. But the wifi problem has not happened since then. It's certainly not the only time I turned the phone off, so I have to think that taking the battery out for a couple of seconds reset something.

  • 1
    No idea what's causing that, but as a work-around: Try switching to airplane mode and back might be a little more convenient than restarting the device. – Izzy Dec 27 '15 at 23:09
  • @Izzy, it actually takes 3 steps: airplane mode on, airplane mode off, and wifi back on. Probably quicker than a restart, but more work. – JWWalker Dec 29 '15 at 21:32
  • If WiFi was before switching to airplane mode, it should be on after switching airplane mode off. To minimize steps, you could utilize an automation tool like Tasker, to place a shortcut for a task on your homescreen – then it would be a single tap. – Izzy Dec 29 '15 at 21:43
  • 1
    @Izzy, yes, you'd think that if wifi was on at the start, it would come back on after airplane mode is turned off, but that's not what I experience when wifi was in the weird on-but-nonfunctional state I've been seeing. – JWWalker Dec 31 '15 at 3:01
  • 1
    I have something similar with my Nexus 10 with Android 5.1.1, it happens now & then. I looked into About and then Status and saw, that it has received 2 IPv6 addresses, but none for IPv4. Turning wlan off and on again fixes it. – ott-- Jan 13 '16 at 17:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.