-3

I waited a long time to get the home screen in the emulator, but i didn't get it. How to proceed from here? emulator loading

  • How long have you waited? Kill the emulator and restart it – Tamoghna Chowdhury Dec 28 '15 at 6:19
  • No wonder it's slow. Intel HAXM emulator acceleration seems to be turned off. Install the Intel drivers from the SDK Manager to speed things up. – Tamoghna Chowdhury Dec 28 '15 at 6:20
  • Your AVD RAM size is higher than that of the HAXM's maximum RAM size. – Lucky Dec 28 '15 at 7:20
  • Next time try to use more informative title for your question. – Άνδρας Dec 28 '15 at 8:33
1

Maybe you can try to use an emulator snapshot.To use a snapshot with your device, open the AVD manager from the Android Studio menu by selecting Tools→Android→AVD Manager, edit the AVD by clicking on the Edit symbol, then check the “Store a snapshot for faster startup” option.

This will save a snapshot of what the memory looks like when the device is running. The emulator will be able to restore the memory in this state without booting the device.

Besides, when you create a new virtual device, you can set its CPU type similar to your development machine(e.g. If your machine use a particular type of Intel x86 CPU, then set your virtual device's CPU to x86 architecture). Also, installing HAXM will help accelerate the speed. You can find it on https://software.intel.com/en-us/android/articles/intel-hardware-accelerated-execution-manager.

What's more, you can try to use GenyMotion instead of the original AVD.

Finally, running apps on your real device will offer you a more efficiency way to test the code.

In your case, it seems that your HAXM memory configuration(max 1024MB) cannot fullfill the AVD(1536MB) according to the screenshot. So you could adjust the HAXM max memory configuration by running the HAXM installer again. When the installer prompted to adjust the max memory size, set it to a number bigger than 1536MB, such as 2048MB. Then reload the AVD, the HAXM would run correctly, and the speed will improved efficiently.

1

the reason is your haxm is not working is that, that your AVD and HAXM both must be configured to use same amount of memory(not sure if lower memory in avd will work).

you can change HAXM memory by reinstalling it(could not find any better method). during installation you will be asked to enter the desired amount of memory.

and you can change the avd memory from avd manager by clicking on the icon and then editing the avd by clicking the pencil button in the right, then go to advanced settings and you will see the memory option(might need to scroll on lower resolution screen)

0

use genymotion emulator. It is fast comparing to general emulator. Program execution is fast than general emulator.

0

Things you can try,

  • Your AVD RAM size is higher than that of the HAXM's maximum RAM size. You can see in the log that,

    emulator: AVD RAM size = 1536
    emulator: HAXM max RAM size = 1024 
    emulator: You might want to adjust your AVD RAM size and/or HAXM configuration to run in fast virt mode.
    

So you need to adjust and set your virtual device's RAM lesser than that of max HAXM RAM size. I would suggest 512mb or 768mb for your AVD.

  • The first startup can take a while, especially on a slow machine but otherwise try running the adb logcat command to see the log output. That will help you determine what the problem could be.

  • Delete the emulator and create a new one

  • Un-check the 'Snapshot' option and restart your emulator.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.