The same thing is happening with the new Gmail as happened with Voice Search. This again?

adb remount

adb shell rm /system/app/Gmail.apk

adb uninstall com.google.android.Gmail

  • Okay, so just FYI that DIDN'T work. And now I don't have Gmail anymore. – tooshel Sep 22 '10 at 1:02

I installed it simply by going to the market and updating to the new version. I know I have it installed correctly as it popped up a "What's New" dialog on first run.

I have a HTC Magic 32A with CM6.

  • I tried that but I get the "Installation of 'Gmail' unsuccessful" message I always get for updates google apps on Cyanogen. – tooshel Sep 22 '10 at 0:33
  • I did the same thing on my Motorola Droid on CM6 without any problems. – Bryan Denny Sep 22 '10 at 0:34
  • I have a Nexus One and so far nothing is working. Might upgrade to a nightly for fun, especially since gmail is gone now. – tooshel Sep 22 '10 at 4:31
  • Okay, like every computer issue a reboot solved the problem. After I deleted Gmail I couldn't install the new Gmail but after restarting my phone the install went fine. – tooshel Sep 22 '10 at 18:30
  • Good to hear that it worked for you. I do have a occasional weird problem where it thinks that I'm running it for the first time and keeps popping up the "What's New" dialog. – Soo Wei Tan Sep 23 '10 at 4:27

You need to install the Google apps for Cyanogen. Download the signed zip from the link below, there is one for the ROM (you don't need) and one for Google apps. All you have to do is install it from recovery just as you would a custom ROM. Should solve your problems...


UPDATE: The link above is for the HTC Magic. The one below is for Nexus One. Not sure if there is a difference in the zips, but just in case use this one for Nexus One.


  • I did that before and all was well but then I went to install the new gmail app (with priority inbox) and I kept getting the "installed failed" message. I'm going to have to install from recovery again though to get it back since I ran "adb shell rm /system/app/Gmail.apk" in an attempt to install it later from the market (which still failed even after running that). – tooshel Sep 22 '10 at 4:31
  • So attempting to reinstall with the file in that link still does not work? Try it again. If it still doesn't work then you are probably going to have to reflash Cyanogen. Before doing anything with ADB you should always create a NAND backup. I wrote a guide on all this for the Evo but most information would still apply to other phones. I recommend reading it... forum.xda-developers.com/showthread.php?p=8104698 – Webs Sep 22 '10 at 12:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.