1

I just got a new BLU studio G and after configuring my google account I can access my gmail, drive and other stuff, except for Play Store and Hangouts. I went to my account settings on the web and in the activity tab I saw my phone listed there, I can also go to the store from the browser (Opera by default, don't know if that helps) and though I can browse it, I cannot install/download anything as it says that I don't have any registered devices.

I have read this article and most of the links it has, tried almost all possible solutions, but resetting to factory settings, and still nothing. Right now am downloading an update of the store app (version 6) and will see if it works.

I even downloaded a VPN to rule out there was something wrong with that,but nothing changed.

So my questions are: what could be wrong with my configuration and how can I fix it?

0

I finally made it to work, I'll be posting what worked for me so it hopefully helps someone facing the same problem.

  1. I manually downloaded the latest (version 6 as of now) of the PlayStore app on my PC and installed it on my device
  2. Then I went to the apps configuration and cleared cache data on all Play services I could find.
  3. Then rebooted my phone and that was it

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.