2

When I try to change the "Notifications mode" using the volume key, it always defaults to "Alarms only" mode, but I would like this to be set as "Priority only".

I know I can swipe down to access "Do not disturb" and set the "Priority only" mode but I want to do it with volume keys

Is there any way to set "Priority only" as default mode when using Volume keys

  • I wish I could help you. 5.0 and above have terrible volume settings. – user186920 Dec 9 '16 at 21:41
  • @beeshyams I wasn't able to set the priority mode as default mode yet. Can you please share step by step. I am using Nexus 5. Here is another question on this topic android.stackexchange.com/questions/150748/… – Gopi Dec 14 '16 at 5:41
  • @beeshyams Sorry but every time I press my volume button down, I don't see any way to reach the priority mode. Can you please give me the direction to do this? – Gopi Dec 14 '16 at 7:27
  • Also, as you told "silencing the volume + being on Vibrate + further decreasing volume = priority mode" is what I am looking for... – Gopi Dec 14 '16 at 7:29
  • @beeshyams sorry for the delay... I will try this by the weekend and let you know. Thanks and appreciate your effort and help – Gopi Dec 16 '16 at 4:57
4
+100

Alarm mode is activated when Vol is decreased progressively reaching silence first, next vibrate and on further decreasing the volume (watch closely and you would notice these steps). OP has clarified that this the behavior expected except that desired end mode should be Priority mode instead of Alarm mode

Since we are talking of changing the default behavior of OS, one way could be to root the device and tweak or use an app. may be preferred option, since it doesn't involve rooting & modding. Many apps are available. I prefer using MacroDroid , since it is free (upto 5 macros) and easy to learn. To understand how MacroDroid works and required settings (app guides you through the settings - make sure from the app settings you activate ignore battery optimisations, my answer here. The drawback of automation approach is that it won't perfectly replicate the expected behavior and has snags, which are mentioned at end

You would need two macros for this

First macro would look like this (Triggers / Actions / Constraints are added by +)

Macro : Vol Silent / Vibrate (name of macro )

Trigger : Volume Button PressedVolume DownUpdate Volume

Actions:

  1. Set MacroDroid VariableNew VariableCreate New Variable→ Give it any name (here ring) and set type to Integer → Set (variable name) → Value = 0

  2. If ClauseConditions +Ringer VolumeVibrate or Silent . Press this If clause and choose Add Child Action. Next, Set Macrodroid Variable, choose the variable name (step 1) and set it to 1

Constraints: No Constraints

Logic: We need to identify when silence or vibrate is reached by Vol Dn . In the first action we named a variable and set it to 0 and in the second action, we set a flag (MacroDroid variable =1 ) to indicate that silence or vibrate is reached. Not specifying any Constraints means we want the macro to always run

In the next macro, we make sure that if the Volume is further decreased from silence or vibrate state, we set it to Priority Mode. To ensure that it happens only when this state is reached, we use the flag as constraint and re-initialize the variable to 0

Macro : Set Priority Mode (name of macro )

Trigger : Volume Button PressedVolume DownUpdate Volume

Actions:

  1. Set Priority ModePriority

  2. Set MacroDroid Variable (name you chose, here it is ring) → Value = 0

Constraints: MacroDroid Variable (ring)Value = 1

enter image description here enter image description here

OK , I had mentioned that it isn't perfect, mainly because you are trying to override default OS behavior without rooting and modding. So, here are the glitches :

  1. If you pause decreasing volume on reaching Silence / Vibrate, or if you are on vibrate and decrease volume further - it won't work

  2. Sometimes , even if you decrease volume smoothly without pausing, you would still see Alarm mode instead of Priority mode. Reading the app logs indicates that this is because both the micros require a few milliseconds to kick in and by then OS has done it's job ! Workaround is to increase the volume a bit and then decrease it, maybe a couple of times allowing the app to do it's job

  3. From Priority Mode, when you increase the volume, it still displays the same status (unlike in alarm mode) , so you need to manually click End Now

  • 1
    +1 for amazing effort, totally looks like it works (haven't tried though) – owlswipe Dec 14 '16 at 21:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.