I recently rooted my htc desire and installed cyanogenmod 7.0.3 and now whenever I use the music app it will play the first 40 seconds of a track then there is a long pause and the next track starts. This happens both with and without headphones plugged in. Can anyone suggest what might cause this and how to fix it.

EDIT after upgrading to cyanogenmod 7.1 I started to get Force Close after 40 seconds on DSP manager.

EDIT 2 I have cleared the data on the music app and tried alternative music apps and the problem persists, also as I said it happens with or without headphones so it's not headphone related.

EDIT 3 This problem seems to be specific to ogg files.

EDIT 4 The problem occurs with winamp, songbird and the built in music player but not PowerAMP

  • This could be way off, but I know many music players have an Intro mode that will play first part of song.
    – Chance
    Sep 12, 2011 at 19:10
  • Have you tried clearing the data for that app?
    – ale
    Sep 12, 2011 at 19:28
  • Possibly similar: android.stackexchange.com/questions/11607/…
    – ale
    Sep 12, 2011 at 19:29
  • Do you have the same problems with video files? Sep 16, 2011 at 21:37
  • I haven't got any video on my phone to test with. I'll see if I can find something appropriate.
    – Col
    Sep 21, 2011 at 15:18

1 Answer 1


Col, without some additional information, I can only give one real suggestion.

Did you install CyanogenMod correctly? Whenever installing a custom ROM on a phone when coming from a stock or older / different custom ROM, you need to wipe: -Cache -Data -Dalvik Cache

If you go to the CyanogenMod Forums, you'll see this is question/step 1 in remedying any bug/glitch caused by CM.

The best way to do this is to go into your phone's Settings menu, go to Privacy (or wherever HTC puts it - maybe Storage), and do a full factory reset. If you moved from stock, CM6, or another ROM to CM7 without conducting a FULL wipe, there is no point in attempting to troubleshoot this problem until you have. Make a Nandroid backup in ClockworkMod, and perform a full factory reset (whether in the Settings menu or in the Clockwork Recovery UI), please. Please note that I am not saying return to the stock ROM, just wipe everything. If this doesn't work (which I'll be surprised if it doesn't), then there may be other issues.

  • I'm afraid I did do the wipe when I installed, I actually did the update again just to make sure after I first found the problem. I went straight to CM7.0.3 from the stock rom at which point I did the full wipe and then from there to 7.1-RC1 when I did the dalvik wipe but not the full wipe.
    – Col
    Sep 20, 2011 at 19:00
  • Well, what format are the songs you're attempting to play? MP3? Bitrate? Do the files play fine on your computer?
    – DavidAP
    Sep 20, 2011 at 19:05
  • They're ogg files, at 128kbps. They play fine on a PC and were fine on the phone until the upgrade
    – Col
    Sep 21, 2011 at 15:18
  • Does the problem happen with MP3 files?
    – DavidAP
    Sep 22, 2011 at 3:20
  • The problem doesn't seem to happen with mp3 files.
    – Col
    Sep 23, 2011 at 16:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .