1

I acquired an LG G2 (LG-D802T 32 GB) that is running the most recent stock firmware. I'm trying to install Cyanogenmod on it. However, I cannot root it. The most recent firmware is patched against various rooting tools, including ioroot and Stump Root. I cannot find an alternative way to root this phone.

Are there other ways of rooting the LG G2? Is it necessary to root the phone in order to install Cyanogenmod, or are there other alternatives (e.g. "download mode")?

(I think I can first revert to an earlier firmware version that is unpatched, but cannot find an image for my model.)

EDIT

I've attempted rooting with the "New Root Method for LG Devices", adapted for Linux. This did not work. I also tried the more recent "Newest Root Method for LG devices", adapted for Linux, which also did not work.

I'm wondering what the dangers are for flashing the wrong firmware for my model. I know that there is an image for the Australian LG-D802T, but I don't know if this is for the 16 GB or the 32 GB. After downgrading to this image, this may hopefully re-expose the vulnerability required for rooting. If I accidentally flash the (incorrect) 16 GB version, but immediately install a custom ROM anyway, would that be a problem?

  • 1
    Have you checked xda-developers? – cricket_007 Dec 31 '15 at 3:22
  • Have you checked the Cyanogenmod wiki? – xangua Dec 31 '15 at 17:44
  • @cricket_007 Thanks for the tip. I've found one guide, although I'm struggling a bit with Windows drivers. I'll try to adapt it for my normal OS (Linux).I'll report back shortly. – Sparhawk Dec 31 '15 at 22:21
  • @xangua Yes, I linked the wiki in my question. They recommend ioroot, which doesn't work, as per my question. – Sparhawk Dec 31 '15 at 22:22
0

I booted into Windows, and again attempted the most recent "Newest Root Method for LG devices". Similarly to when I tried it in Linux, this did not work, with the terminal freezing on the Send_Command.exe step. However, I cancelled this (with Ctrl+C) and tried this step again. This time it worked and I was able to root my phone. (Possibly, if I had tried it multiple in Linux it may have worked.)

I could then install Cyanogenmod as per the wiki, with a few caveats.

  • FreeGee did not support my device, so I used AutoRec instead.
  • The latest nightly cm-13.0-20160108-NIGHTLY-d802.zip refused to boot, so I used the latest release build cm-12.1-20151117-SNAPSHOT-YOG7DAO1KI-d802.zip instead, which is working fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.