0

I have rooted my Huawei P8-Lite ALE-L21 with superuser.zip. After successful root I tried to change superuser app. So, I have installed KingoUser.apk and after that I have clicked on superSu app -> settings -> switch superuser app. It didn't work. So, I installed Link2SD app and converted KingoUser as a system app. Now, when I launching SuperSu or KingoUser, some warning message pops up and says that the su binary needs to be updated.

There is no way to flash my phone cause Huawei haven't released my build version as a stand-alone flash file.

How can I unroot my phone now ?

migrated from superuser.com Dec 31 '15 at 7:49

This question came from our site for computer enthusiasts and power users.

1

Part 1 Unrooting Your Device

You can unroot your phone from SuperSu itselef

Go to SuperSu > Setting > Fullunroot.

Part 2: Replacing KingUser

You can download the ready to use script for replacing it with SuperSu Here

  1. Download Zip file from site
  2. Extract it in External Sdcard
  3. Launch Terminal Emulator
  4. Type su and give the superuser acess
  5. Type sh /sdcard/mrw/root.sh
  6. Script will automatically delete all Kinguser files amd will make SuperSu as system app
  7. Update SuperSu binary
  • The default mount tool that comes with stock Android has its usage as Usage: mount [-r] [-w] [-o options] [-t type] device directory. – Firelord Dec 31 '15 at 13:36
  • 1
    When you mount a partition from fresh, you do mount DEVICE_IDENTIFIER MOUNTPOINT. E.g., mount /dev/mmcblkp3 /system. When it comes to remount, you pass the option remount. If you want to remount at same location, you need not to pass device identifier, so it can be mount -o remount /system instead of mount -o remount /dev/mmcblkp3 /system. In order to mount in read-only or read-write mode, you pass ro or rw as argument. There are exceptions with mount tool in certain devices where you must mention device identifier during remount. – Firelord Dec 31 '15 at 14:42
  • It's not working at all, and when I'm trying to use su with adb, this error goes up: error: only position independent executables (PIE) are supported. – OMiD Jan 2 '16 at 5:47
  • Try su command from Terminal Emulator and see whether you are getting superuser access..If not than you can unroot as mentioned in answer..and can root again – Ash-Ishh.. Jan 2 '16 at 13:20
  • i have tried that, same error. – OMiD Jan 2 '16 at 13:32
0

I don't think the question matches its title. However, this answer is for people who might arrive here in search for an answer to the question asked in the title...

how to delete system app using zip file.

First, see this answer where I explain how to create a ZIP file for flashing .apk files. Follow that explanation but use an updater-script like this:

mount("MTD", "system", "/dev/block/platform/mtk-msdc.0/by-name/system", "/system");
delete_recursive("/system/app/SomeApp");
unmount("/system");

Where SomeApp is the directory containing the .apk for the app that you want to delete (use an adb shell to acertain this path).

One could, however, just use adb shell to do it (but this doesn't answer the question asked):

$ adb shell
shell:/ $ su
root:/ # mount -o remount,rw /system
root:/ # rm -r /system/app/SomeApp
rppt:/ # reboot
0

Be careful! If you rashly attempt to install SuperSU after rooting with KingoRoot, your device would be bricked even if you uninstalled KingoRoot. KingoRoot will NOT completely remove itself when you uninstall it. The ONLY way to remove KingoRoot completely is to flash the stock ROM.

So, no, don't.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.