So I'm kinda stranded after accidentally wiping out my whole internal storage.

I'm trying to install a temporary ROM e.g CM on it via USB OTG on TWRP.

My phone doesn't have an OS on it. I have no PC with me since I'm on holiday.

I tried downloading the 200 meg CM and found a flash disk lying around.

However it has the Xbox fuse file system on it, which TWRP is not picking up. All I have access to is my Android tablet.

So I'm trying to find some sort of file manager that allows the disk to be formatted. Any leads?


2 Answers 2


You could try any of the following:

  1. The Android pendant (port) of GParted for Linux, AParted. It currently does not support the exFAT file system, but supports most common Linux file systems and FAT32, and it can detect unmounted partitions and format by block device id. It can auto-repair drives too. Here is it's online manual.

  2. What @Firelord suggested:

    • Get the block device id of the flash drive by using the blkid command from TWRP's "terminal emulator" option under the "Advanced" button.

    • You could try mkdosfs -v [-n Label] BLOCKDEV KBYTES, where all the options have been explained above. This will format the block device to FAT32, if the binary is available (I think it is present in busybox and CyanogenMod), otherwise:

    • Do what @Izzy suggested in @Firelord's linked question:

(The working directory should be /system/xbin/ or /system/bin/, whichever has the busybox binaries installed to it. Also, all commands must be run as root (su -c before anything else))

mkfs.vfat [-v] [-n LABEL] BLOCKDEV [KBYTES]

What do those options stand for?

-v: Generate verbose output (reporting)

-n Label: Give the file system a name

BLOCKDEV: the file system (block device) you want to format

KBYTES: probably the block size in KB(I'm not 100% sure with this)

So the minimal thing to do would be:

mkfs.vfat -v /dev/block/uba1

(provided your drive to format is available as /dev/block/uba1 on your system). One more example, giving the file system a name:

mkfs.vfat -v -n MyNewDisk /dev/block/uba1

It should report success then -- or an error if it failed.

  • Shouldn't it be su -c instead of su? Unless, -c is mentioned, what comes after su would be treated as the userid shell to be switched into.
    – Firelord
    Jan 1, 2016 at 13:15
  • Don't get it wrong, but posting unverified answers doesn't help much. Please make it a habit to verify things.
    – Firelord
    Jan 1, 2016 at 13:17
  • @Firelord, I actually meant "issue an su command before issuing anything else". That, at least on my devices, switches to the root user's context for any following commands. Jan 1, 2016 at 13:19
  • 1
    @Firelord, these commands can be run from either TWRP or the OS, but in this case I imply the OS whenever I do not specifically mention TWRP Jan 1, 2016 at 13:25
  • 1
    @Firelord, TWRP asks for a starting directory on opening the Terminal. I thought the mentioned directory would be a safe option. Jan 1, 2016 at 13:26

I would suggest you to try this tool -- Paragon exFAT, NTFS & HFS+ . It is available as .apk files on the net or you can download from Google play as well.

But i would seriously suggest waiting it out and doing formatting throiugh tried and tested methods via PC (just to negate any slight chances of renedering your drive useless which does happen when making file system changes using smartphones)

here are the links


  • Nope. One of the 1st things I tried. It couldn't even see the fuse file system.
    – user111175
    Jan 1, 2016 at 12:00
  • @HarrryPorter then you should wait it out maybe?
    – user301926
    Jan 2, 2016 at 4:01
  • Nah. I already mkfs.vfat 'd at the TWRP terminal and formated it.
    – user111175
    Jan 2, 2016 at 6:05

You must log in to answer this question.