I'm trying to root Lenovo vibe p1ma40 with Lollipop 5.1 this particular device since last couple of day, without any success. So I need your help to do this, or not this particular device but it would be good if there will be generic solution for root of android device.

Below is list of techniques that I've already tried :

1) KingoRoot, and other apps - seems they are under development for this particular device.

2) SP Flash Tool(link) - device go to charging mode after step-8.

3) Fast boot(link- METHOD 1) - command fastboot boot recovery.img gives error as - FAILED (remote: download for partition 'boot' is not allowed) or - command fastboot flash recovery recovery.img gives error as - FAILED (remote: download for partition 'recovery' is not allowed)

4) New Flashing Commands(link) - command fastboot flashing unlock_critical gives unknown command error.

Any help would be highly appreciated, Thanks in advance.

  • Unlock the bootloader first using the command: fastboot oem unlock (Note: Unlocking bootloader formats the User data (/data partition). So make a backup of apps/settings first). Then flash/boot the recovery :)
    – Gokul NC
    Commented Jan 1, 2016 at 13:16
  • That third link is specifically about Nexus 6P, so why are you using them on your non-Nexus 6P? The instructions there are bound to fail on your device.
    – Firelord
    Commented Jan 1, 2016 at 13:43
  • @Gokul - Tried this command too. Even after execution of this command and then following method 3 as describe above gives error. And no this command doesn't format any data.
    – Chitrang
    Commented Jan 1, 2016 at 13:52
  • @Firelord - I've installed latest adb with fastboot for Ubuntu and linux while in Ubuntu these commands are not displaying but in Windows these commanda are diplaying in help.
    – Chitrang
    Commented Jan 1, 2016 at 13:56
  • So I thought if it has something to do with android lollipop 5.1 then let me give it a try.
    – Chitrang
    Commented Jan 1, 2016 at 14:02

2 Answers 2


For the technique 2 that you have listed, you have to install the USB VCOM drivers in your computer so that SP Flash Tool can detect your phone and to enter Download Mode via the USB VCOM port.

This action will add the following drivers in to the operating system:

MediaTek DA USB VCOM Port
MediaTek PreLoader USB VCOM Port – for transferring the firmware to your device
MTK USB Modem Port
MTK USB Port – for transfering PreLoader to your device (and recovery in case of bad or corrupt firmware)

Source: http://laurentiumihet.ro/technology/windows-10-mtk-vcom-usb-drivers-for-32-64-bit-drivers-installation-tutorial/

This should definitely work and help you root your phone.

For your technique 3 (using fastboot), I think you get the error:

FAILED (remote: download for partition 'recovery' is not allowed)

Because you need to unlock the bootloader to flash the recovery.
This varies a little bit for different phones. The most common command to unlock bootloader is:

fastboot oem unlock

Before doing this, do this: (this might be required sometimes)
1. Go to settings -> About Phone -> Tap on "Build Version" until it shows developer, may be 7 times.
2. In Settings -> Developer Options -> Enable OEM Unlock.

After doing this, still if you're unable to unlock the bootloader or flash recovery using fastboot, I would recommend you to seek further help from the Lenovo Forums.


No need of any other methods. Just use kingroot. Its best. It didn't work for me for about 3 times. 4th time it worked. Use latest kingroot app

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .