17

I'm using Sony Xperia Z3 compact running Lollipop 5.1.1. My proximity sensor is really faulty (Works only when I press hard on the top left corner of the phone). I'm sure it's the proximity sensor because I used test apps and I can see it's detecting proximity all the time (unless I press hard on the corner).

Obviously, my biggest problem with that is that my screen goes dark when I make a call (Because the proximity sensor think the phone is near my ear). Trying to use the power button to turn on the screen didn't work so I set the power button to hangup calls (Otherwise I had to wait for the other side to hang up!).

I've seen many (many!) posts about this issue and tried all the apps who claimed to turn off the proximity sensor and non worked (including using the service setting at *#*#7378423#*#*) :

  • KeepScreen
  • Screen On Call
  • Screenbl - Screen On/Off Sensor
  • Smart Screen On Off
  • Disable Proximity Sensor
  • Proximity Fix
  • Proximity Screen Off Lite
  • On Call Proximity

I gave them all admin permissions and whatever they asked, but they all failed... The proximity sensor is just too strong for them I guess...

My only hope is to find an actual dialer app that has an option to ignore the proximity sensor (Used to be a popular option in the past). The Xperia Z3 compact default dialer does not have this option, nor the following dialers I've tried (At least I couldn't find that option):

  • Turedialer
  • DW Contacts & Phone & Dialer
  • Dialapp: KitKat Dialer
  • Reactiv Phone Dialer
  • Contacts+
  • KK Phone (KK Dialer, Lollipop)
  • Ready Contacts + Dialer
  • pixelPhone Pro

The only app I've found to have this option and it actually worked really well was: Viber, but unfortunately Viber cannot be used as a regular dialer but only as viber-to-viber dialer or viber-out dialer (like Skype credit).

So please, if you know of a dialer which you're sure has the option to ignore proximity sensor (or: 'keep screen on during call' as it sometimes called), please share it with. Any other original ideas will be welcomed as well.

  • Are you familiar with Tasker? – Aman Thakkar Jan 6 '16 at 5:58
  • @beeshyams - these commands would not work for xperia z3 compact. the directory seems to be wrong. Any chance you know what could work for my phone? – DMEM Jan 6 '16 at 15:20
  • @AmanThakkar - I downloaded Tasker. Could you elaborate more on what I should do with it? – DMEM Jan 6 '16 at 15:21
  • @ProductManager I'm sorry, I thought you could maybe disable the sensor during call but turns out it's not possible that way. I'm looking for other ways though. Are you having any problems after setting Power button to disconnect? – Aman Thakkar Jan 6 '16 at 16:28
  • 1
    If you're willing to root Android and install Xposed Framework, then I can say that the module, Disable Proximity, worked perfectly on my Android 5.1.1 (non-Sony device) – Firelord Jan 6 '16 at 20:38
9

I'm sure some of the solutions that were mentioned here will work for other people but unfortunately, the only solution that worked for me was a hardware solution. I took my phone to a lab and they pressed the screen to the back of the phone with some extra glue. After 24 hours the phone was good as new. As a programmer I was disappointed that no software solution could solve my problem, but I still feel obligated to share my solution.

  • Thanks for the visual explanation about the glue - despite the fact that pressing the corner worked, I still hadn't understood to what extend the screen was completely loose! – Tao Jun 25 '16 at 14:36
  • @Tao I think it was a few millimeters. It was impossible to see when looking at the phone from the front but a little visible when looking from the side. – DMEM Jul 5 '16 at 20:30
  • Yep, exactly the same here. – Tao Jul 6 '16 at 6:46
  • The software solution which worked for me was [installing Xposed framework](v), and then using this Sensor Disabler app. As I say, this has worked for me in the past, but right now I'm struggling to free up the /system space to install xposed framework. Very frustrating. – Robin Winslow Jul 15 '16 at 12:32
  • the problem just happened to me exactly the same few days ago, I don't know the main reason but it is so ! and actually I don't want to trick my device using some (disabler, tasker app or something like that) then is the problem unsolvable unless I take the device to some repair stores ? is it sensor calibration error and needs to be re-adjusted or what ? – wisdom Oct 23 '16 at 14:10
2

The only way I managed to work around this issue with Macrodroid was to:

  • put the trigger to volume button (up)
  • put the action to reject call.

So when I make/receive a call, I can end it with volume up button.

Works on Z3 Compact.

1

You could try this solution to keep screen on during call using MacroDroid automation app (Root not required)

To get an idea of how it works, settings required, testing/ troubleshooting, see my answer.

Additional setting for this solution is from main panel of app SettingsTrigger OptionsProximity Sensor TriggerEnable Work with Screen off

Your macro would look like this (gets activated once the call is active )

Trigger:

Proximity Sensor → select Far (can be tried with near also)

Action:

Screen On/offScreen on

Constraints:

Call StateIn call (Macro runs when you are in call)

Disclaimer:

  1. Tested on Huawei Honor 6, running Kitkat
  2. @Firelord had confirmed, it is not working on his Lollipop version. Don't know if it is Lollipop / ROM / Device related. In the MacroDroid forums, reference is made in one post only to not working satisfactorily on Moto G but confirms working fine on Samsung S5, both running Lollipop. Request OP to confirm, whether it works or not on his device
  • Nice try but unfortunately didn't work. Cool app though... I did managed to control other phone settings like the torch or the Bluetooth but couldn't keep my screen on or cancel the affect of the proximity sensor (even after the special settings you've mentioned). – DMEM Jan 7 '16 at 20:33
  • the macro has being called. I've emailed you and the developers, the log. – DMEM Jan 9 '16 at 16:07
  • Thanks. Seen and replied to developer. He is a one man team so may expect delay in reply. Let's hope it is resolved – beeshyams Jan 9 '16 at 16:16
1

Have you tested the Proximity sensor on the device, as this sounds like it may be related.

Try the following.

Menu > Settings > About phone > Diagnostics > Test Device > Tap Ear Proximity

If this fails, make sure to remove any covers or Screen protectors and then test again, if it does work, then the Proximity sensor was being covered or obstructed.

1

Using Tasker:

Profile name: Screen on

Conditions:

  1. Call Any, * +
  2. Proximity Sensor

Tasks

  1. Menu (any title, any settings. This is to turn the screen on to show a menu. You can also use Pop-up if you want, though it may not work)

  2. Display Timeout (To keep screen on immediately after menu has popped up. Set it to any suitable time you wish to)

This worked for me, and lights up the screen during call. It is tough to replicate your problem because I don't have it myself, but you can try it out.

Edit: If you're considering rooting, I guess many apps will work. Also, please check if you have the option of : Turn on and Stay on. They aren't available on my phone but may be available on yours. Or maybe you will need root access for that.

This is what I mean:

Screenshot

  • Can you use an easier template to follow? I had to figure out (not follow) what you intended in your profile. Consider using a template like Izzy uses. Whatever I figured out didn't work so I'm waiting for a revision in your answer. Export your profile if you can't make the answer more easier to follow. – Firelord Jan 6 '16 at 20:02
  • @Firelord I'll do so shortly – Aman Thakkar Jan 7 '16 at 10:30
  • @AmanThakkar I'm with 'Firelord' on the template request. Not really sure what you meant in your answer. Will appreciate a more 'step-by-step' guide. – DMEM Jan 7 '16 at 20:44
  • Please try it out now. I've simplified my answer. Hope it works. – Aman Thakkar Jan 8 '16 at 5:36
  • The simplification it requires can be represented this way: Profile: Event -> Call Any, Profile: State -> Proximity Sensor. The location may differ, but the point is to make it easier to follow. How does a person is supposed to know where is Call Any or Proximity sensor located? – Firelord Jan 8 '16 at 17:35
0

Yeesss! I had the same problem and plan to waste my phone!

Macrodroid help me to resolve issue with proximitity! Proximity sensor - always tell - NEAR. And i can`t finish a call or input digit - screen was locked.

Remedy is - install Macrodroid and create macros Trigger: Proximity Sensor → select Near Action: Screen on Thats all! My phone working fine now!!!!!! Beeshyams, thank you very match for your cool mind and big heart! p.s I can swith off screen by botton!

  • What type of phone is this? Doesn't work for me whether I set the proxomity sensor to be a "trigger" or a "constraint" (Sony Z3 Compact) – user568458 Jun 13 '16 at 17:01
0

I have actually been having this issue since i bought this phone in February and i have been to lazy to take it back. I decided to call sony after my phone irritated me beyond explainable today and he asked me to go into - Settings - About phone (if it is your first time in there click agree) - Diagnostics - You then need to select the test tab - Scroll down all the way to the end and select 'ear proximity' - Now it will tell you to place your hand over the sensor and if it vibrates it means your sensor is fully functional. If it vibrates from the moment you select ear proximity then your SENSOR IS FAULTY :(

He told me that if i bought it out wright i have to send it to sony for about 14 days so they can see what is wrong with it and if it is repairable... Never again will i make the mistake of buying anything other than apple.

protected by Community Jul 14 '16 at 1:04

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.