2

On my rooted Motorola Moto G 2014 LTE I can no longer access the directories under /storage/emulated/0/, such as Download, Documents, Ringtones.

Using a file explorer, without root access, I just get access denied when trying to open the folder; with root access, I can open the folder but I am unable to write in it. Folder permissions seems ok (770, owned by root and group sdcard_r).

Using a terminal emulator, trying to do an ll inside the folder (as root) returns opendir failed, Permission denied.

What I did prior to the problem was:

  • unlock the bootloader, install TRWP recovery
  • root
  • install various apps (including Link2SD to move some apps to the SD card)
  • perform a nandroid backup
  • trying to flash Xposed: I had some issues here after reboot, so I restored the nandroid backup

Another thing to notice: after the nandroid restore, an app installed before making the backup (FX File explorer) was missing.

EDIT: I solved with a full wipe (not just factory reset) and restoring again the previous backup.

  • @Firelord I've read from various sources that the "fix permission" tool is deprecated and actually does more harm than good on Lollipop. In the end I just solved with a full wipe and another nandroid restore, and the problem was gone. – dipanda Jan 4 '16 at 13:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.