10

I have a contact that is shown twice in the contacts list. The copies are not from different accounts (so they cannot be joined), they are not two different entries in the same account(so they cannot be merged in Google contacts online), it is exactly the same contact. If I edit one, the other gets also edited.

  • I have tried joining them on the phone, it says "contacts joined" but nothing happens. The two copies are still there.

  • I have tried deleting the contacts, but when I delete one of them then I cannot access the remaining copy in the list as tapping on it shows the message "the contact does not exist".

  • Another strange thing is that one of the copies does not belong to any account at all. When displaying one account contacts only (eg Google contacts, Whatsapp, etc.) it shows only one copy (the same for all accounts containing the contact, it is a joined contact).

  • Finally, it is worth mentioning that this happened after installing Whatsapp and this contact has two mobile numbers associated so it appears twice in contact list inside Whatsapp. I do not mind having the same person twice in Whatsapp, but I would like to have only one copy in my contacts list on the phone.

What can I do?

Edit: I have removed my Whatsapp account from Settings->Accounts and the duplicated contact has disappeared. As soon as Whatsapp synchronises again, it appears again.

I have also noticed that it is the only contact with two mobile numbers and each of them has its own Whatsapp account so that there are two different entries in the contact list inside Whatsapp. I have other contacts with two mobile numbers but only one of them is associated to a Whatsapp account and appears only once in both Whatsapp and Phone contact lists.

is it then a Whatsapp bug? is there someone else with the same problem?

  • My mother has the same problem on her Redmi 2. I used to have it too,but now I don't and I don't remember how I got rid of it 😶 – Aman Thakkar Jan 5 '16 at 14:24
  • Did you find the answer useful? – Aman Thakkar Jan 6 '16 at 5:52
  • check the format of the number, remove brackets and such, add country dialing code. – TiloBunt Dec 13 '17 at 7:22
1

Somewhere in Settings you can see Contacts to display

Now it shows different options like Show All Contacts, Device Contacts, SIM Contacts, Whatsapp Contacts and of all accounts that you have. Simply select your desired option as mine was to show SIM Contacts. 

  • can you offload device contacts somehow? – Thufir Jan 3 '17 at 14:39
0

Due to the lack of details like screenshots, multiple apps I would be answering it as a what's app case

Principle: The basic principle is that every name has only one contact number storage space if you're storing it in sim card but if you're storing it in phone memory then only it would support multiple numbers to a single name.

What's app assigns every contact a single number just as in sim storage. Now if under contact settings/display you select to show all contacts I.e Phone, sim,whats app, email, gtalk etc then you will end up with multiple name display so far that you need to choose a single location where would you Store your contacts (settings menu is standard on all Android phones but only the appearance may vary due to the OEM flavour on top of Android)

-Normally i save all new contacts in sim to have it safe just in case there's system failure and it's formatted and later copy it to the memory card.

-After that I hide the sim contacts display, all other's app contacts display in phone , merge duplicates with this I avoid duplicate display of contacts from each and every app installed and get a summarised display.

Note

  1. While saving contacts with same name and multiple no on sim card just add a identifiable suffix like name.1 so on so forth.
  2. Later once you hide and merge duplicates then you won't get multiple names to worry and what's app would take all the names from sim card so you will get the names as you saved.
0

Open WhatsApp, goto Settings and un-check "Show all contacts" check-box.

0

I was getting the same issue in my mobile. Now I find the below solution for this issue. I am using Mi Note 3.

Go to setting. Go to System apps. Go to contacts. Click on Display preferences. Click on Configure contact list and select your google account. (If you want to see only whatsaap contacts then select whatsapp)

  • Did you take this from a website? If not, there's no need for quoting it like this, but if you did, you need to include the link to the website as well. – user186920 Nov 13 '17 at 23:33

protected by Community Nov 29 '17 at 6:17

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.