10

When I'm on a call my screen turns off after X seconds. Half the time I can't get it to turn back on without pushing the on/off button, which I have set to terminate a phone call (because half the time I can't get the screen to turn back on). Is there a way to just turn this "feature" off?

In case it matters:

  • Phone: Samsung Vibrant
  • OS: 2.2 / FROYO.UVKA6 / 2.6.32.9
  • 1
    It's turned of so that you don't accidentally press a button while talking. – kyrias Sep 11 '11 at 13:20
  • See android.stackexchange.com/questions/8667/… TL;DR - Use Screebl – Sparx Sep 11 '11 at 15:57
  • I have a Motorola Droid 1, and on my phone, the screen "wakes up" during a call when I pull it away from my face. I'm not sure if it's a heat/motion sensor or something, but considering the Vibrant is newer than the Droid 1, I'm sure your phone works similarly. – Cody Capella Sep 11 '11 at 22:59
  • @BigCaseyDog Its a proximity sensor which is nothing else then a simple light sensor. If you cover it, Android assumes that you put the phone on your ear, whereupon it disables the input. – Flow Oct 11 '11 at 16:30

15 Answers 15

15

Keep screen on during calls

That setting is not available on all phones, but if it was it would be under: Home > Settings > Call Settings > [Display >] ...

But as for the difficulty turning the screen on

Be sure that the power button does not end calls (Settings > Accessibility > Power Button ends call : make sure it is UNchecked)

Then just pull the phone away and press the power button to turn the screen on.

  • Part two of your answer did the trick. I guess I'd only tried the volume keys before to "wake it up"; the power button works, too. Thanks! – Joe Casadonte Nov 29 '11 at 20:47
3

Are you sure that the screen goes off after X seconds? Android phones with proximity sensors usually turn off the screen when they are put on an ear. The Phone should automatically turn on the screen if you uncover the light/proximity sensor (e.g. by removing it from your ear). The Galaxy S does this and I suppose that the Vibrant does so too, because they are basically the same phone models. Other Android phones behave similar.

I am not sure if it's possible to disable this feature. Even if so, you would encounter another problem: Accidental pushing buttons on the touchscreen with parts of your face, which could lead to hang-ups.

  • On 1.6, my Droid had this problem, too. Some percentage of the time the screen would not wake up when you moved the phone away from your face. It went away with the 2.1 or 2.2 upgrade. – TomG Nov 29 '11 at 2:34
  • I suspect this is the same on my phone, only it hasn't gone away with any updates :( – Joe Casadonte Nov 29 '11 at 20:37
2

You can disable the proximity sensor or simply go to call setting and you will find an option that reads keep screen awake.

  • I guess T-Mo took that option off the Call Settings page... – Joe Casadonte Nov 29 '11 at 20:40
  • maybe, but on a standard unlocked android phone the option exists. – Aadi Droid May 19 '12 at 16:31
2

I had been having exact same problem for a few months on my LG-P500, but have just fixed it. I found that the proximity sensor had gotten covered with dust as the screen cover had slightly lifted in the area of the proximity sensor. Once I cleaned it off it worked fine again.

1

I'm not quite sure how to turn the feature off but when I had my Droid Eris, it would do the same thing. I found that if I simply hit one of the volume buttons on the side, the screen would come back on without having to end the call.

1

I have noticed (while searching like mad to put my phone in a universal waterproof case for my handlebar, where the proximity sensor is hidden), that when the Bluetooth is on the screen stays on during a call.

Also, as Brian says here, when I'm on a ride with the "Strava" app running and I receive a call, the screen goes black, but if I press the "back" button, it goes back to Strava with the screen on.

0

To keep the screen and disable the proximity sensor launch another program while on a phone call. The screen will remain on while the phone is against your ear.

  • +1, works. Pressing the home button to put the call app into background also works, you need to wait a second for the effect to be switched off though. – ce4 Nov 5 '12 at 19:03
0

If you enable the touchpad while the call is coming in, the screen will stay on even when the phone is pressed against your face. For instance, if you answer a Google Voice call and have to push "1" to pick up the call.

Of course, this will result in you repeatedly pressing the buttons with your face, causing GV to say "this call is being recorded" and possibly hang up, but hey, you asked for it.

0

02-09-2013 - When the screen goes dark (by factory default) while on a call can be very frustrating. I just purchased a new Samsung Galaxy Proclaim, an Android phone, and this solved the problem.

Go to Settings > Accessibility > Power Button ends call : make sure it is UNchecked

Then when the screen goes dark while you're on a call and you need for it to come back on for pressing prompt numbers, account numbers, or whatever....just press the power button to turn the screen on. Since you've unchecked the end call by pressing the power button...the screen will now come back on and will not end the call. Hope this helps.

  • 1
    You noticed the OP explicitly checked that feature because he wants to be able to end a call, and the screen didn't turn back on? So your suggestion just brings him back to where he was before: Being unable to get the screen on, AND being unable to end a call. – Izzy Feb 9 '13 at 23:56
0

I lived with this problem for a few months but eventually I hit my breaking point.

  • Searched Google & tried other suggestions for fixes
  • I realized I just wasted way too much time...

So I came up with a plan of my own:

  • ripped the phone apart
  • unplugged the sensor from the board
  • turned the phone on to test & it worked!
  • I have an S4 and on my hardware this sensor was attached to the audio jack as well
  • I needed my audio jack still so I ripped the sensor off the audio jack and threw it in the garbage with much satisfaction
  • put everything back together
  • lived the rest of my life with one less phone problem
  • 1
    Software workarounds are usually better (of which there are several). – Enigma Oct 29 '14 at 13:36
  • Point missed: "* voided my warranty for good" – Izzy Oct 31 '14 at 12:18
0

does your device have shake your phone to activate camera feature? If so just shake phone then hit back button to get out of camera mode. Also on some phones it will light up screen when plugging into power or unplugging.

0

I have the same problem of the screen dimming in my LG during a phone call. It matters because I have to sit and listen to really long conference calls, and I have to be ready to turn off Mute to answer a question.

I haven't found the settings that have been mentioned. My only work-around is to be in another app, and when I have to go to the phone, I click the call icon in the 'Second Screen.'

So, now I have one tap instead of 2 taps to wake the phone. That's a marginal improvement.

-1

From your description, it sounds like there may be an issue with your proximity sensor. The proximity sensor should turn off the screen instantly when you put the phone to your face during a call. The way you described the screen turning off after X amount of time sounds like it's just normally timing out. You can use an app called AndroSensor to test the functionality of your proximity sensor. This would also explain having to turn the screen back on manually instead of it happening automatically. Also, you may want to look closely at the sensor, there may be dust on it preventing it from working properly.

As others have noted, the Vibrant should have an option for disabling the sensor. Is this option already checked? That may have something to do with it.

-1

I found a couple of settings in Cyanogenmod which could be useful. I am not sure if they are available in vanilla Android.

enter image description here

Also, the proximity sensor application in HTC is pretty good. But I am not sure about Vibrant.

-2

The best way that I find is to cover the screen for a few seconds and then release. This is the same mimic as if you are calling into voicemail or a feature for which you are required to press a key. This is the best means that I have found to keep all features enabled. BTW: I find it odd that you have the power button set to hang up. I believe this is a feature you setup in order to advert another issue. Maybe solving the hang up feature problems will assist with this one as well?

  • 1
    I've tried that hand trick repeatedly -- no joy. I set the power button up to hang up because I couldn't wake up the screen to hang up calls... – Joe Casadonte Nov 29 '11 at 20:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.