I've completely wiped my Google Nexus device. I still have Team Win Recovery Project. But, seems that the device isn't detecting USB.

Executing adb shell returns error: no devices found.

Executing adb devices doesn't return my device.

Tried it out on bith Windows 8 and OSX (El Capitan).

  • My device (non-Nexus) is detected in MTP mode as well when I boot it in TWRP. Have you checked in your OS in PC, that an MTP device shows up when device is in recovery mode? What kind of image do you have? Can they not be flashed using fastboot? – Firelord Jan 5 '16 at 17:00
  • 1
    @Firelord: Nope, no devices show up. – xan Jan 5 '16 at 17:01
  • 1
    @Firelord: I tried many images. CW recovery, CynogenMod 12, others. It gets stuck on < waiting for any device > – xan Jan 5 '16 at 17:04
  • "USB Debugging" enabled in Settings - Developer Options? – DukeSilversJazz Jan 5 '16 at 17:38
  • Does this happen in Android itself as well as in recovery environments? – LJD200 Jan 5 '16 at 18:08

I've resolved it. Used a different USB cable and got everything fixed!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.