0

I recently switch from Helium backup to Titanium (still free version). I tried to use the scheduled backup and experienced a quite annoying effect: I ran the backup at 3am in the night - and my alarm scheduled for the moring was not working.

It seems that titanium stops apps for doing the backup (I think I read this somewhere), and my interpretation is that the alarm clock app cannot exec scheduled alarms once it has been stopped.

Is there a way I can exclude the alarm clock app? In fact, I really don't need a backup of my scheduled alarms ...

I run CyanogenMod 11 / Android 4.4.4

  • What's the issue with the clock? Yes, TiBu might need to stop apps to make a clean backup (RESTART_PACKAGES). I run scheduled backups every night, and have no issue with that. The Alarm Clock doesn't need to run continuously; for alarms, it gets "awoken" by the system (alarms are registered with the system). Btw: Running CM 11 here as well on multiple devices using different Alarm Clocks. And the full (paid) version of TiBu. – Izzy Jan 7 '16 at 11:40
  • I just improved my question above; I experienced that the alarm clock was not working in the morning :-( – Pedi T. Jan 7 '16 at 12:49
  • 1
    Can you also 1) add which alarm clock you are using, and b) try if the same happens with a different alarm clock? I have a nightly TiBu job running at 3am (as you do), alarms never failed me (firing around 6…7am). I use the "default clock" on one device, and AlarmDroid on another, both devices running CM 11/Android 4.4.4. Additionally: what kind of batch backup are you performing (e.g. all apps, changed only, …)? I could then compare with mine. – Izzy Jan 7 '16 at 13:32
  • I used the CM 11 standard alarm clock app (however it is called). Good idea to try another one. It was the standard "backup changed data" job in Titanium without any modification. – Pedi T. Jan 7 '16 at 18:36
  • 1
    I have a Galaxy Nexus and I used nightly TB backups (free version) with the last Android update Google provided (4.3) and never experienced this, but recently I installed 7.1.1 AOSP from XDA and indeed, since I did, I can confirm that TB now stops the clock app and doesn't restart it. When the notification says that the clock app is being updated, the clock in the status bar indicating that an alarm is set, disappears, and doesn't come back until the clock app is restarted manually. – MoonSweep Dec 9 '16 at 5:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.