2

I was on vacation for two weeks and took a couple of photos with my smartphone camera (Samsung Galaxy S3). When I came back home I connected my smartphone to my computer to copy the photos to a "safe location", however I could not find the pictures on my phone. There were only pictures saved by apps (Telegram&WhatsApp) and very very old pictures.

Actually I also noticed that for some of my Apps (very, very few) the icon was replaced by a ghost symbol and an "SD card" symbol in the corner. If I tap it, it says "application not installed". After some testing I figured out that I can reinstall these apps and also take new pictures, but they are reproducibly gone after a restart of the phone.

There is no error message at any time except the mentioned "application not installed".

  • Could my vacation pictures have suvived somewhere? If yes, how can I revover them?
  • What the hell is going on? Or how can I find out what is going on?

What I tried

When I connect the microSD card with an SD card adapter to my computer and try to access it with dolphin it says:

An error occurred while accessing '59,5 GiB Removable Media', the system responded: The requested operation has failed: Error mounting /dev/mmcblk0p1 at /media/yankee/45BC-6301: Command-line `mount -t "exfat" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,iocharset=utf8,namecase=0,errors=remount-ro,umask=0077" "/dev/mmcblk0p1" "/media/yankee/45BC-6301"' exited with non-zero exit status 1:
stdout: `FUSE exfat 1.1.0
'
stderr: `WARN: volume was not unmounted cleanly.
ERROR: fsync failed: Input/output error.
'

From lspci I know about my card reader:

b:00.1 SD Host controller: O2 Micro, Inc. OZ600RJ0/OZ900RJ0/OZ600RJS SD/MMC Card Reader Controller (rev 05)

It is a built in card reader of my Dell Latitude E6520.

Another "normal" SD card with 128 GB formated with exFat can be used normally with my computer, but nevertheless I found some posts on Google that suggested that the error may as well be connected to some incompatibilities somewhere between card reader, card and driver. However due to lzzy's comment I also tried:

$ mkdir /tmp/ttt
$ sudo mount -o ro "/dev/mmcblk0p1" "/tmp/ttt"

and to my surprise this worked! And to my disappointment my vacation pictures are not available.

To fix this I tried:

$ sudo fsck.exfat /dev/mmcblk0p1 
exfatfsck 1.1.1
WARN: volume was not unmounted cleanly.
Checking file system on /dev/mmcblk0p1.
File system version           1.0
Sector size                 512 bytes
Cluster size                128 KB
Volume size                  59 GB
Used space                   19 GB
Available space              41 GB
Totally 499 directories and 2997 files.
File system checking finished. No errors found.

However as we can see here this did not fix anything. Additionally sudo badblocks /dev/mmcblk0p1 completed without any output at all.

  • 2
    Could it be those "lost pictures" have been stored on the external SD card? We had a similar issue here not that long ago, also with a Galaxy device (Ace 2). Turned out the SD card had given up, not "holding a charge" anymore. What you saved there stayed as long as the "file system cache" had it. Checking the card for bad blocks (using a card-reader attached to a PC) showed the card seemed to consist of nothing else anymore but bad blocks. Try with a card reader then: copy something to the card, unmount, mount, check if it's still there. – Izzy Jan 7 '16 at 23:10
  • @lzzy: Sounds legit. Plz see my extended question. Post your comment as answer so I can accept it. Is the SD card still worth anything or is it trash? (Bonus question: Why is android doing this to me? Why is it not just saying when I take a photo "sry could not save" or something? Is there any technical reason or is this just stupid design?) – yankee Jan 8 '16 at 12:30
  • As you run Linux: try the badblocks command against the card. The remaining questions of your comment will be answered with my answer then (spoiler: it's not Android to blame, but rather the controller of the card I assume). – Izzy Jan 8 '16 at 12:58
  • @lzzy: sudo badblocks /dev/mmcblk0p1 took a long time, but terminated with no message at all. – yankee Jan 8 '16 at 23:59
  • It takes a long time, yes. And the outcome was other than I expected (in my case, it spit tons of errors right at the start – so the card was gone for good, which explained the behavior, see my first comment). You are correct however that there are sometimes incompatibilities between cards and devices. // As for your photos, I'm afraid they're gone. You could try the card with PhotoRec (see our data-recovery tag-wiki on file carving). – Izzy Jan 9 '16 at 1:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.