-1

I am using Samsung Galaxy Superior running on cm 12.1, and I am losing space on my flash(Internal Storage). I tried to delete all the files on it, but I find I am still lack of space. The composition I get in the Settings > Storage is :

  1. 1 giga apps
  2. some small media files (less than 10MB)
  3. free space 1 giga.

My drive is 4 GB so I am losing 2GB of it. When I turn to ES File Explorer, it tells me that there are some 2 GB "other files". How can I fix this problem? Please help.

  • That "lost space" might be logs (see here) and/or tombstones (see here). – Izzy Jan 8 '16 at 9:31
  • That's no use. I don't have the /data/log folder, and tombstones only have 2~3 MB. There must be something else, because I tried to clean things in the /data folder. – Chromium Jan 9 '16 at 4:10
  • I finally find out who is taking my space. It is in the /data/media folder. I move them to the SD card and everything is okay. But can you tell me what is the folder for? – Chromium Jan 9 '16 at 4:47
  • Wha… I'll be damned. Thanks a lot for that comment! I had thought those data lost already. Have you done an OS update recently? I've just checked with my devices, and found it on one I recently updated and thought the content of the internal SD card lost afterwards. Now I've found it, in /data/media. And remember the background: Before Kitkat, that was where the internal SD card was placed. Since Kitkat, that went to /data/media/0 (I've upgraded from 4.1.x; the change actually was with 4.2: Why did /sdcard/ turn into /sdcard/0/ with 4.2?). – Izzy Jan 9 '16 at 13:26
  • Actually, I am using lollipop... The stuff in that folder seems to be something long time ago when I am using 4.1.2 JB. And the Internal Storage changed to /storage/emulated/0 – Chromium Jan 9 '16 at 13:32
0

You are not "losing space", it's just left-overs from a past Android update. Back then when your device was running Jelly Bean 4.1.2, /data/media was the place your internal SD card was allocated. With 4.2, this location changed to /data/media/0, see Why did /sdcard/ turn into /sdcard/0/ with 4.2?

So when your device was updated to Lollipop, it located the internal SD card in /data/media/0, but did not migrate the contents from the old location. You've propbably thought then the card was "wiped" during that update (as was I when updating from 4.1.2 to 4.4.4 on one of my devices), but Android simply left the content where it was. Moving it to your SD card (as you did) thus was the perfect solution.

Hint to other readers: Moving that content will most likely require root powers, as without root you cannot access directories below /data directly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.