0

On my Motorola Moto G XT1068 with 5.0.2 whenever I'd turn on "location" it would ask permission to use high accuracy mode, and if I remember rightly, send information to Google. I always chose disagree because I don't want to do this.

Today I was helping a friend trial an app and in order to get it to function properly I was forced agree to this. Now I have two problems:

  1. When I turn location on it always defaults to high accuracy, I cannot get it to default to device only
  2. I have no idea how to revoke this permission that I agreed to

So, my questions are: 1. How can I get it to default to device only? 2. How can I revoke this permission?

Ideally I don't want to have to do a factory reset. And yes, I know, I shouldn't have said yes if I didn't agree, but silly me assumed I could easily revoke this permission.

  • For first part: Toggle location services via adb in Android 5. I'll see what I can do for second part: Toggle location services via adb in Android 5. Is the Android rooted though? – Firelord Jan 9 '16 at 1:05
  • When you long-press the location quick setting, you would be shown a screen. There, change Mode to Device only. Tell us the result after switching location on/off multiple times. – Firelord Jan 9 '16 at 1:07
  • @Firelord as I said, it always defaults to high accuracy, no matter how many times I change it or turn location on and off – Phill Jan 9 '16 at 1:10
  • 1
    Can't say whether it would work, but deleting Play Services' data works here. Reboot after deleting the data and make sure location is turned off. There is something to be said about Google Services Framework as well. Two keys in one of the databases are network specific that affects the location mode toggle, but Play Services contains the crux I believe. If you can afford to lose Play Services' data, then try following my suggestion. – Firelord Jan 9 '16 at 3:00
  • 1
    That got it. The original message is now appearing again and the location mode goes to device only. If you want to write that as an answer I'll accept it. – Phill Jan 9 '16 at 3:24