3

Someone gave my daughter a (hardly) used Samsung Galaxy S2, still on Gingerbread.

Did a lot of research online (rooting for dummies guide, S2 specific sites, youtube videos, etc) and managed to

  1. Successfully Root it and installed CWM based recovery v6.0.5.1

  2. Installed Resurrection Remix Lollipop specific for my S2 device (i9100)

It was a successful install, for 2 weeks. My kid used the new Lollipop ROM with no problems (except the occasional freeze, but still reboots OK).

Then one day, it just froze and won't reboot to OS anymore.

Symptoms:

  • Boots up, shows the logo for 2 secs, then shuts down. We took out the battery for hours, recharged the battery, still the same.

  • Entered back to Recovery Mode, Wiped cache partition, Dalvik cache (and later, various storage area space) and tried to Install a ROM zip again (Resurrection Remix).

    AT FIRST, it shows that its installing for a few seconds, then shuts down.

    After several repeated attempts, it won't even show any progress, as soon as I choose the file and select it, the device shuts down.

    Then it reached a point where even wiping cache will cause the device to shut down.

    Plus, its getting increasingly difficult to enter Recovery Mode. It now takes me several attempts to boot back into Recovery Mode.

    Download mode (Odin Mode) I can get into without much difficulty though.

    I even downloaded a different ROM (CYANOGEN+OS+12.1S+V.1.0+s2+GT-I9100) but it won't install either (also shuts down).

    Now Device just boots and gets stuck at the Samsung logo, and as I said, it's really difficult now to get back into recovery mode.

    Is this a hardware issue or is there something else I can try?

2

Using Odin, I'd reflash the original official rom for your device (you can download from sammobile.com), this is to restore the original partitions. I'd format all current partitions in recovery, check your mounts that they all are unmounted. The system partition should be mounted before formating (I usually mount everything then format all). Reboot into download mode, hoping that your recovery options allow that. Plug into odin and flash official firmware, you might lose your root access and custom recovery should you be unable to use the hardware buttons to boot into recovery immediately after the flashing completes. If so, repeat your rooting procedure, custom recovery installation and finally, lollipop again... P.S. Without a log, chances of getting specific assistance is greatly reduced. Use ADB to diagnose any exceptions and errors thrown.

Remember to always make a full backup of the complete system before flashing new roms, or have the official ROM should such things occur, and they do...

Try a different ROM, or even better, look into building your own ROMs in the future... That's where the fun is...good luck and happy flashing

  • thanks for the advice... unfortunately, ive been trying to download the firmware for the Galaxy S (I9100T), but have had no luck from sammobile.com (using the FREE DL...I'm hoping I can get it somewhere else before I go to the Paid DL...) Yes..my Bad... I didn't backup the existing firmware (Gingerbread), thinking its so old, I could just use a different custom rom or an updated one if something goes wrong... dang it. Will explore further options and be back here for an update. Meantime, I could still use advice (or help in procuring said firmware) if any can offer it... thanks again :) – DeeSee Jan 12 '16 at 11:31
  • UPDATE: Finally got the S2 working again. Managed to dl the firmware from sammobile.com (I chose a different ver). Initially had problems flashing... turned out the culprit is a BAD BATTERY. It says 90-99% charged but ODIN says its low battery.. maybe that's why the unit kept shutting down after each Wipe? Anyway, with a new battery, managed to flash the stock firmware with ODIN, Re-Rooted it, and Installed a new Custom Rom (Minimal OS for S2). So far so good... Thanks again for the advice and also I wanted to leave the updates here in case others encounter a similar situation... – DeeSee Jan 18 '16 at 11:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.