2

Ever since my phone came from Motorola service centre after a SIM slot repair some things are wrong with it.

1)Like the title says, Google Chrome's tab switcher is stuck in accessiblity mode. I've tried uninstalling and updating, factory reset, chrome://flags accessibilty setting and also upgraded to Marshmallow but it's still the same.

Here's a screenshot from an XDA-Thread. chrome tab switcher

I've looked at many places but haven't found a solution. Seems like only some people are having the problem.

2)Google now offline commands have stopped working as well and "Ok Google detection" from any screen option is missing as well.

Google voice settings

Can anyone suggest any solutions?

0

So after looking a lot and not getting any solution, I decided to flash my firmware. Reinstalled the stock factory OS from scratch and now it's good as new and the problems mentioned above are solved.

The following is for Moto G(3rd Gen).

Here's a simple tutorial an how to do this by lost101 of XDA: http://forum.xda-developers.com/2015-moto-g/general/guide-fastboot-flashing-factory-t3187750

The link to the page with factory firmware images is also mentioned on the page above.

Make sure you download the right firmware according to your phone model.

Now I ran into an issue with my wifi after flashing with fastboot(My phone couldn't detect wifi during the initial android setup), so if that happens, use mfastboot(I think it has better compatibility with Motorola devices). Just google to download the latest version. The commands for mfastboot are same as fastboot; just replace "fastboot" with "mfastboot".

Also note that this doesn't void your warranty as long as you don't unlock your bootloader, so make sure you don't type any wrong commands. The commands mentioned in the XDA-thread should be enough.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.