1

On my Xperia Z1 compact and cm 12 I used the Dark Material theme. Then after a recent update it was disabled 'after too many app crashes'. I tried to set it again but now every time I go to settings->themes it exits with the error 'unfortunately, settings has stopped'.

Some posts on the web suggest that in settings->apps, clearing the data for the Theme Chooser app (under All Apps) will solve it. But there is no Theme Chooser app in my app list.

Is it possible to (re)install Theme Chooser somehow? Or another way to be able to switch Themes in cm 12?

phone: Sony Xperia Z1 compact (amami) OS: cm 12.1 update 20160110 android: 5.1.1

EDIT

I tried (re)installing the Themes APK generously provided by the author of this post, but when I open the APK it first says "Do you want to install an update to this built-in application? Your existing data will not be lost. The updated application will get access to New|All", and when I choose either of those it exits with "App not installed."

That means that Theme Chooser is still on the phone. But why does it then not appear in the "All Apps" list (which would allow me to Clear Data)?

EDIT II

I dirty flashed the latest image (15/1) from the cyanogedmod website. Still no theme chooser that works.

11
  • Tell us whether these commands solve the issue: adb shell su -c am force-stop org.cyanogenmod.theme.chooser; adb shell su -c pm clear org.cyanogenmod.theme.chooser; adb shell su -c am force-stop org.cyanogenmod.themes.provider; adb shell su -c pm clear org.cyanogenmod.themes.provider ; adb reboot;
    – Firelord
    Jan 16, 2016 at 9:31
  • Also, what does this return: adb shell pm list packages -d?
    – Firelord
    Jan 16, 2016 at 9:32
  • adb shell su -c am force-stop org.cyanogenmod.theme.chooser -> unknown id: force-stop. Same for the other force-stop command, and both clear commands return unknown id: clear.
    – alle_meije
    Jan 17, 2016 at 15:12
  • The other command returns package:org.cyanogenmod.wallpapers.photophase package:com.android.camera2 package:com.google.android.launcher package:com.google.android.gm package:com.android.wallpaper.holospiral package:com.android.phasebeam package:org.cyanogenmod.themes.provider package:com.cyanogenmod.wallpapers package:org.cyanogenmod.theme.chooser package:com.cyanogenmod.filemanager package:com.android.musicvis package:com.android.dreams.phototable package:com.android.wallpaper.livepicker package:com.android.email
    – alle_meije
    Jan 17, 2016 at 15:13
  • 1
    without su -c I can execute those first 4 commands, but after reboot I still get Unfortunately, Settings has stopped.
    – alle_meije
    Jan 17, 2016 at 15:23

1 Answer 1

0

After using adb to remove the data for the packages org.cyanogenmod.theme.chooser and org.cyanogenmod.themes.provider, as suggested above and elsewhere, and also after cleaning the data in trebuchet on the phone (by way of trial and error), the only thing that really made the Theme Chooser work again was a clean flash:

  • download the latest cyanogenmod (and Google Apps if you want) to your sd card (remove /system/* too if you are switching to Open GApps from another GApps)
  • reboot into recovery (on an Xperia Z1 Compact by repeatedly pressing volume-up at boot)
  • choose wipe data / factory reset and empty cache
  • do install update for both the CM and GApps ZIP files
  • reboot

After reboot, my apps were re-installed via my Google account and the data (images, documents) from before flashing were all still there.

The custom wallpapers and (in my case no) sounds needed to be set anew.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .