0

I installed Badland from Play Store. It worked. Then I uninstalled it and tried installing it from Amazon Appstore. Every time I try to install it, I get the installing screen for about a minute (long time) and then the error "App not installed"

I found the apk file (from my filesystem, the one Amazon downloaded) and the exact same thing happens when I attempt to install it. I have redownloaded it many times.

I also have root and I'm running Android 5.1.1

EDIT: The message I get from terminal is: [INSTALL_FAILED_VERIFICATION_FAILURE]

  • Can you confirm the info mentioned in first paragraph of the answer for How to completely uninstall an app on Android Lollipop? If yes, follow that same answer for the remedy. – Firelord Jan 12 '16 at 22:06
  • There is a good chance the App from Amazon Playstore is unsigned - have you tried allowing 'Unknown Sources' in Security Settings ... why not just install it from Google playstore again? – Mark Keen Jan 13 '16 at 1:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.