0

I'm having this problem since I was trying to upgrade Aptoide from 6.5.X to 7.X.

I was trying to upgrade Aptoide from inside Aptoide: Installation failed.

I was trying to adb install or pm install it, got the same response:
Failure [INSTALL_FAILED_CONFLICTING_PROVIDER]

So I removed the older Aptoide version and got the same response exactly except for several times where I got Failure [INSTALL_FAILED_INVALID_URI].

I tried upgrading my CM version (My device is OnePlus One with the latest official COS12.1), didn't help, same response.

I checked the list of packages, there were no conflicts with the name in android:authorities in AndroidManifest.xml and there were also no special character in that file (I used apktool to decompile the apk and look at the files).

I have no idea what I'm doing wrong but I don't want to mess with the package and there's nothing I know I can change in my phone's configuration that would fix that.

Any ideas?

0

Figured it all out!

Apparently Aptoide-dev was installed but somehow only for the guest user.

All I had to do was switching to the guest user, going to Settings -> Apps and remove the Aptoide-dev package.

Going back to my profile did some weird stuff (I can't switch between apps, it'll probably work after restart) but I managed to install Aptoide finally.

Thanks.

-1

Try the "Blackmart" application, i was using aptoide but couldn't find every app i wanted. Link > http://www.blackmart.us/

Anyway if it's a thridparty app (which thirdparty apps are installed as .apk) you should go to Settings > Applications > And then enable Unknown resources it 'Allows installation of non-market apps'

I hope that helped and worked

  • 1
    The second paragraph isn't making sense. OP has explained that even installation from adb is failing and has mentioned the error code as well. Unknown sources settings has nothing to do with that. That setting comes into action if only you're trying to sideload using GUI. – Firelord Jan 14 '16 at 2:33

Not the answer you're looking for? Browse other questions tagged or ask your own question.