5

All the guides that I can find online refer to the Windows-only "Odin" software. I also found an open-source alternative "Heimdall" but the Samsung S6 is not supported (and apparently it's not compatible with the .tar.gz file format).

I have installed WinXP on a VirtualBox virtual machine, and then I installed the Samsung USB drivers and the Windows Odin software. I then made sure to route all Samsung USB devices to this virtual machine, but still neither Windows nor Odin sees the phone - neither in its normal operating mode nor in its "Odin" download mode.

Chainfire's CF-Autoroot also uses Odin, which means I'm still stuck at the above problem. I also tried running Odin in Linux (using wine) but again it couldn't see the phone, and I didn't expect it to work anyway).

I have not been able to find a description of how to root the S6 (or any Samsung) directly in Linux, or via virtual machine. Is that simply not possible? Do I really need to install my old WinXP license on a physical computer?

  • Scroll down to the comments, it shows somebody did it with Linux androidguys.com/2015/04/22/…. And Google threw this up for a different model all-things-android.com/content/how-root-samsung-mobile-device – beeshyams Jan 13 '16 at 15:02
  • 2
    There is a program called "Jodin" It might do the trick. xda-developers.com/… – Bo Lawson Jan 13 '16 at 16:23
  • @BoLawson: thank you! With JOdin, I came closer than ever. This runs on my Linux (in Firefox, after installing Oracle Java 8), and it reports "connected". But it does not succeed in getting the PIT file from my phone, so I'm stuck at that stage now (and the JOdin support seems to be a 24+ page long forum post). I dare not download a "random" PIT file from the Internet; the risk of choosing the wrong one is too high. – Torben Gundtofte-Bruun Jan 13 '16 at 19:53
  • @BoLawson, I'd love to give you credit for your suggestion. Care to submit JOdin as an answer? I would revice/remove mine instead. – Torben Gundtofte-Bruun Jan 13 '16 at 20:46
6

There is a cross-platform version of Odin called JOdin. It can run in a web browser, or locally after downloading the JAR file. Either one requires Oracle Java 8 to be installed first.

Web version: https://builds.casual-dev.com/jodin3/
Offline version: https://builds.casual-dev.com/index.php?dir=JOdin3%2F '

The offline version is started with $ java -jar /path/to/JAR/JOdin3CASUAL-r1035-dist.jar.

Both versions work well - but now I run into the next problem which is that the PIT file can't be obtained.

0

I know this is old, but you need to make sure you present the USB device to your VM ;) (at least if you still want to do this from a VM) --- At least for anyone finding this off of the googles

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.