0

I currently possess a Nexus 7 Tablet running Android v4.1.1 with Kernel v 3.1.10-00001-g2cd7831 which was given to me as a Christmas gift. The packaging it came in looked new. It uses the standard browser that comes with the phone not google chrome (can't download because I don't have Google Play). After having done the following steps I am still unable to launch Google Play Store:

1) Tried to locate it in Settings->Apps->All and nothing was there.

2) Did a factory reset and checked again, nothing.

3) Downloaded the .apk for the latest version of the app from http://www.apkmirror.com/apk/google-inc/google-play-services/ and attempted to open, only to get a white window pop up and immediately close. Crash.

4) The app is not disabled.

5) Cleared cache and data for the app and restarted tablet.

6) Re logged into my gmail account.

7) Settings->Apps->Reset App Preferences and still doesn't work.

I'm afraid I am all out of options I am aware of. If you can suggest any fixes please post!

Thanks ahead of time.

8
  • 1
    You need to download GApps (Google Apps) appropriate for your Android version. Play Store requires Play services and latter require files which doesn't come with its APK.
    – Firelord
    Jan 14 '16 at 1:27
  • I seem to be having a difficult time downloading it from teamandroid.com/gapps on my pc and trying to transfer the files. Is there a certain way I should try to do this? When I try to download directly onto tablet it just says the download failed. Jan 14 '16 at 2:15
  • The download is working fine here. That said, I didn't completely download the file so can't say more. Try some another source.
    – Firelord
    Jan 14 '16 at 2:19
  • I was able to queue a download and finish it but the end result says download failed. I downloaded: CyanogenMod 10.0 Android 4.1.1 – 4.1.2 – Jelly Bean HDPI / MDPI / TINY: gapps-jb-20121011-signed.zip – (Mirror #1) Jan 14 '16 at 2:26
  • Did you download through desktop or tablet? Jan 14 '16 at 2:27
0

I found someone with the exact same issue I was having here: Forum Android-Central and the solution starts at comment #9. After going through the steps I have resolved this issue. Thank you for your help!

Thanks to RumoredNow on Android-Central for the following solution:

It's good that your bootloader is unlocked. That saves a step and means that you can flash images..

Get the NRT. Nexus Root Toolkit v1.8.3 | WugFresh

Once you have that installed it will ask what model you have. Select Nexus 7 (Wi-Fi Tablet) from the drop down. (Not the Nexus 7 v2.)

When you select the Android build you are running it should be NAKASI-GROUPER: Android 4.1.1 - Build JRO03S. That S is the only one authorized for 32 GB models.

Let the toolkit download any other files it needs.

Power on your device as normal.

Go to - Settings and scroll down to the bottom. Second entry from the bottom should be Developer Options. If not, you have to enable developer mode. Settings > About tablet - then find Build Number. Tap on that entry quickly 7 times to enable Developer mode.

Settings > Developer Options > USB Debugging needs to be checked.

Download this file: Factory Image 4.4.3 It is the latest Factory Image 4.4.3 for Nexus 7 2012 WiFi. Or pick another image from the repository. Google Factory Images for Nexus Devices I always thought 4.3 was a very solid release. Maybe research a bit on versions? Make sure you get an image for your model: nakasi - NOT nakasig

Plug the tablet into your computer's USB port. Let the computer set up drivers if it needs to.

Open Nexus Root Toolkit. Find the Flash Stock + Unroot button. Check the space for "Device is on/Normal" and click the Flash Stock button. A new window opens up, "Which Factory Image.". Select "I downloaded a factory image myself that I would like to use instead" and press the OK button. When the "Choose a Google Factory Image" window opens, navigate to the image you downloaded and select that. Click open. Follow the prompts and the Toolkit will do the rest. Your tablet will be completely stock at the Android version you selected except for the unlocked bootloader. I suggest you leave it unlocked in case you need to flash an image again, although the Toolkit will relock the bootloader with the OEM Lock button if you so desire.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.