0

I have a Samsung Galaxy S3 & I have 3 updates in the Play Store. When I click on them they start to download but part way through between 40%-60% they will just stop downloading. The phone looks like it is still trying to download but nothing is happening. Started happening yesterday.

I have tried force stop, clear data and clear cache from the Google Play Store and Google's account manager. Also, tried uninstalling Google Play Store.

I have also cleared the Cache from the Recovery start up (Up arrow, Home, Power button).

Nothing seems to work.

Phone works fine outside of unable to download from Play Store.

Checked system updates and ran Lookout for viruses and everything is fine.

Please help.

Thanks

  • Do you have root access? As that would make it easier. If you don't, then I discourage rooting only for the sake of this download, as it voids warranty and opens up security problems. Do you have a strong enough network? Try using a Wi-Fi and moving closer. Are there any interruptions like sleeping? – TheBro21 Jan 14 '16 at 20:54
  • Do any of them update successfully if you don't choose Update all but individually update one of them? – Firelord Jan 14 '16 at 23:07
0

Talked to Google and they said to try restore phone. Did that for over 1.5 hours and phone said Shutting Down but nothing happened. Called back Google and they suggested to call Samsung. Called Samsung and they help me reset the phone via Power button, Home button & Up volume button. Wiped out everything and started new. Thanks for your help. Phone seems to work now and able to download apps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.