2

I have had this question for quite a long time and I hope that it can actually be done.

I live in Greece, but I mainly use my Android (Lollipop 5.0.2) mobile phone in English (US). The reason is that this is my personal preference. I feel a lot more comfortable having a UI in English.

The problem I have is that when using applications that operate based on locale settings (distance, decimal points, etc) everything is according to the US locale and that's normal.

But I live in Greece and would like, for example, Foursquare to display km instead of miles by default. Even though that's something you can change in settings, the decimal point in the Calculator app cannot be changed (US locale uses . for the decimal point and , for the thousands, while in Greek locale it is the other way around).

So, is there a way (not necessarily a user-friendly one) to fine tune these settings to match the Greek locale, while still using EN_US as the display language?

This does not answer my question. I would also be interested in manually editing the US locale, if necessary and possible.

  • I think it might work for you if you use the English language from a different country. Have you tried English, Britain (en_GB) ? Other options are: <a> English, Australia (en_AU) English, <b> Canada (en_CA) or <c> English, Singapore(en_SG) etc.. – PCM Jan 15 '16 at 0:49
  • Unfortunately they all use . for the decimal point and , for the thousands separator. – errikos Jan 15 '16 at 0:53
  • 1
    Now I am trying to map the list to English locales with [en.wikipedia.org/wiki/Decimal_mark] Countries using decimal comma .So, en_BE: "English (Belgium)" should work -- Can you give it a try? – PCM Jan 15 '16 at 1:10
  • en_NA: "English (Namibia)" is another such example. – PCM Jan 15 '16 at 1:15
  • I have looked for that too. Not all locales are included in system settings, though.I only get US, UK, Ireland, South Africa, New Zealand, Canada and Australia. – errikos Jan 15 '16 at 1:15
0

In principle, no need to download any extra application to your cell phone to solve this problem. Try going to the region or language configuration and change from English from the United States to English from Europe, at least it worked for me like this.

  • You might be right, though for the OP's specific case, no European variants are available by default: "Not all locales are included in system settings, though. I only get US, UK, Ireland, South Africa, New Zealand, Canada and Australia." – Andrew T. Mar 16 at 1:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.