0

I need a little help here since i just started messing with android phones and i guess i messed up this one a lot. I rotted it fine and then i tried flashing a rom through flashify. When the phone restarted i am stuck at the CAT logo and on the top there are two lines of text with red fonts. Top line says fastboot mode, second line says bootimage is not signed.

I have downloaded fastboot and i am able to get some info out of it, so fastboot sees the phone, but when i am trying to flash a boot image or a recovery image on the phone i get the message remote: device not support flash command. The answer is equivalent when i am also trying to erase, boot, recover etc. it says device not support.

Is there any way i can get out of this mess? Really appreciate your help and feedback.

Best wishes guys and happy new year.

  • Are you able to boot in recovery? – Vivek Ji Jan 15 '16 at 11:16
  • Unfortunately not :/ – ikoual Jan 17 '16 at 12:15
1

Had the same problem flashing and trying to boot custom made boot.img. I believe you ARE able to enter recovery (if you have not corrupted both boot recovery images, what is unlikely).

To enter recovery on Cat s50 you need to:

  1. Power off the phone (in your case just hold the power button for several seconds).
  2. Press and hold "volume down" + "camera" (the one between volume up/down) buttons. This is tricky by itself and not so easy from first attempt :)
  3. Holding buttons from previous item you should insert the usb cable into powered usb port (controller or host os seems to be irrelevant, just need to have 5V).
  4. Screen will show logo, but will not blink with our "bootimage is not signed" error. You may release the buttons and wait several seconds - it will show recovery menu.

Now. To restore /dev/block/mmcblk0p24 ("boot") nothing helps but factory update image. I had backed up this partition image before re-flashing - it did not helped - same error with one from back-up. So:

  1. You should download factory image, e.g. from this untrusted source :) https://mega.nz/#F!scdiVLgJ!K7BNoVUTNqaAELWQjsOUnA
  2. There are 2 ways - via adb or sd card - both work fine. Lets describe adb. Go to recovery mode with phone connected to pc (linux in my case). You should select "update via adb" in recovery menu - it will wait till you provide image via adb.
  3. From your pc you enter adb sideload /yourdownloadfolder/update-LTE_S0201121.0_S50_0.023.00-user.zip
  4. Just wait for phone to validate it and restore images (it will say).
  5. Reboot and all should be OK.

Google how to install adb if you don't have it already. To update from sd card just copy that zip file into sd card root and select it with according recovery menu item. Someone recommend placing CID file (also available on link from "1"), but I did not - all OK.

Hope it will help, and if so - need to investigate further how to sign that damn bootimage. I want it to provide network file system support for this phone - all modules are ready and work just want it to be smooth from boot via custom bootimage.

protected by Community Sep 3 '17 at 20:44

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.